Novation Launchpad not detected [SOLVED]


I tried to connect my Novation Launchpad (not the mini version, the original Launchpad, the oldest) but it’s not detected in the USB HOST section (no device connected)

It’s working well on my computer, with the same usb cable

Any idea ?

Thanks !

Enough power? Can you supplement power?

Hi Bruno,

it looks like that the original Launchpad is not a MIDI class compliant device. It means it requires special drivers to be installed on the host (computer) to establish the connection. If it is the case, Electra cannot, unfortunately, recognize it.

I am just guessing based on the following info from the novation support site: Maybe somebody else can confirm?


Hi Markus and Martin !

Thank you for your answers.

Unfortunately, you can’t supplement power to the original Launchpad.

Martin is right: I needed to install some drivers for the Launchpad to work on my mac.

So I think we can close this topic :slight_smile: I will use a newer Launchpad if I truly need that.

Thanks again.