Firmware / Web editor beta testing

This thread is meant for those who are involved in beta testing of upcoming firmware version 3.0.

1 Like

an updated version 3.0-a.2 has just been uploaded to beta.


  • incoming sysex messages are applied to the parameterMap according to the Patch response definition
  • Lua Device object has new methods:
    • device:setName(name)
    • device:getName()
    • device:setRate(rate)
    • device:getRate()

Tested v3.0-a2:

  • fader with “variant”: “fixedValuePosition” displays a broad shadow above the small bar when moving the pot (as if it is a normal, broad, fader).
  • toggle button with a light (eg white “on” colour) should invert its text colour to a dark shade (eg black); now it doesn’t so that in the “on” state the button text is barely readable.
  • changing the type of the visual indicator of the active control set through the editor (configuration tab) doesn’t seem to do anything
  • Envelope controls (ADSR etc) are hard to select (they require quite a long press, and touching the pot does not select the control either); after selecting the envelope the popup shows, but then no information about which pots could control the different parameters (the circles below the envelope) is shown, and actually the pots cannot be used to change the envelope; touch appears to work somewhat)
1 Like

Also some non-bugs, ie things that work/have improved

  • Great, 14bit controllers (range 0…16383) work nice now: slow turn allows for small value adjustments, while quicker turn moves the control with reasonable speed through the whole large range of values. I like the feel of it!
  • Stuck at value problems appear to be solved.

@joris.roling seems like the Electra gets better with 14bit turns :slight_smile:


Yes, I noticed it a bit, but we’ll need some more patience, the Bitwig Control presets still depends on features that need to be done (beta 2)

1 Like

an updated version 3.0-a.3 has just been uploaded to beta.


  • SysEx API has been extended with:
    • Control update message
    • Preset list handling
    • Preset and preset slot switching
    • Notifications on events in Electra

The Controller section of the web app should work with this firmware version.

It would be super cool if presets such as Bitwig Control, Ableton, and Notes Transmittor could be tested. @joris.roling, @jhh, @NewIgnis

re @jhh 's report:

fixedValuePosition will be no longer supported. Instead, number of new visual variants of faders will be added. I tried to reflect earlier input from @jhh. Thus, faders going always from left to right, centered, round knobs will be soon available.

yup, I was planning to ignore this during the development phase, but I will make some quick fix to make it more readable.

yup, I leave this out for now.

This is a thing for discussion. The 2.2 uses LCD long touch and holding of top-left button + LCD click to display the detail. LCD Touch cannot change the value of the control. With 3.0, however, I am playing with the idea that values could be changed. To test it, create a preset with on fader and use the LCD touch to change the value by moving the finger above the control. As 3.0 is multitouch, you can do this with several controls in the same time. Of course, if this new functionality is kept, recalling details and such must be adjusted. I am open to suggestions.

The detail pages (eg large ADSR) are very simple now. There is a change in functionality coming too. It will be revealed soon :slight_smile:


Cool! Will test this out soon.

Hm…not much I can test at the moment as this release of the firmware also supports only one preset. At least, I cannot seem to select a slot: the E1 does (no longer) respond to
(0xF0, 0x00, 0x21, 0x45, 0x09, 0x08, bankidx, presetidx, 0xF7)

What I also saw is that the E1 does not respond to E1_SYSEX_REQUEST = (0xF0, 0x00, 0x21, 0x45, 0x02, 0x7F, 0xF7)

The E1 does send log messages that my remote script happily receives as before. (So it cannot be a connection issue)

Will test soon as well

Apologies… It seems slot selection is possible through the web app but when I send the same sysex from within the remote controller nothing happens; I’m stymied…

Hi @martin

Some beta feedback in conjunction with the Bitwig Control preset:

Electra One v3.0-a.2 still does NOT seem to respond to:
F0 00 21 45 14 07 [ctrlLSB] [ctrlMSB] [json] F7

F0 00 21 45 14 07 02 00 7B 22 6E 61 6D 65 22 3A 22 54 75 6E 65 22 2C 22 76 69 73 69 62 6C 65 22 3A 74 72 75 65 7D F7
json here is {“name”:“Tune”,“visible”:true}

Logs in the Console App (less significant I think, but it shows some SysEx coming in, but not all).

99210 processElectraSysex::handleElectraSysex: electraInfo sysex sent to the host
99217 queueL1: received: interface=1, port=0, channel=1,  type=240, data1=7, data2=0
99244 processElectraSysex::handleElectraSysex: appInfo sysex sent to the host
99244 queueL1: received: interface=1, port=0, channel=1,  type=240, data1=7, data2=0
100141 queueL1: received: interface=1, port=0, channel=1,  type=240, data1=54, data2=0

Ah, got it… 3.0 lo longer accepts SysEx over Port 1.

1 Like

Do I see it correctly that the E1 no longer responds with an ACK after a slot selection?

1 Like

I’m trying to install v3.0-a.3
it goes to “100%”, and then “rebooting”.

The device does a reboot, and states “v3.0-a.3” but does not go any further. The web page states “rebooting” still.

I waited minutes, no change… Console logs in a PM

1 Like

Early remarks.

Update progress on Win10 with Chrome went flawlessly.
But I can’t make the Notes Transmittor to send anything out : please check remarks 5, 6 and 7 first so I can continue testing

  1. The control visuals aren’t good right now. Stuff for later?

  2. Active control set indication doesn’t work anymore, changing on touch is not yet functional, the upper part remains highlighted. The buttons work.

  3. Suggestion for backward compatibility : allow per preset to keep everything in capital letters

Testing the Notes Transmittor / Splitter V4

  1. Reaction to touch is slower than before, not as responsive, as a result it doesn’t change pages, even if the page was highlighted on touch.

  2. The log viewer is functional. Error when changing polychain voices:

    Line 471: local message = valueObject:getMessage()

  3. Error when changing play mode

    This is line 345 : local message = valueObject:getMessage()

  4. I can’t change to another preset . How do I do that?

1 Like

I noticed a similar slower responsiveness to touch when trying to open the details of an ADSR control

1 Like

I did a “top left button” reset, now I’m in… (@martin, I hope you can make sense of the logs I send you)

1 Like

Hi @martin,

I can say that the Bitwig Control preset works lovely.
The UI is still a bit rough (faders seem half drawn, pad text not vertically centered)
But I love the fact that I can tap the pads in the middle without actually changing Control Set area, so the top area stays ‘active’. It seems that ‘Touch switches control sets’ config is not working :blush:
I did have a freeze at some point, sorry, no logs

Here is an photo:


3.0-a.4 has just been uploaded to beta.

  • Electra SysEx messages are now accepted on all USB ports
  • ACK/NACK are sent upon completion API calls

got it. The Lua Midi API has been modified so that the functions take the MIDI interface (MIDI IO, USB device, USB host) as an extra parameter. I will add functions that do not require that - to keep it backwards compatible. ie. when no MIDI interface is specified, the messages will be sent to all MIDI interfaces.

yup, both will be tackled later.


Do you mean the LCD touch or the touch on knobs?

will review

Right now, presets can be changed only with the Controller::Preset slots in the web application. I am about to add the preset selection page very soon. It is becoming too limiting to test stuff.

1 Like