Firmware / Web editor beta testing

I’m of the same opinion, that would solve a lot of challenges I’m currently having, especially with the more complex synths.

1 Like

Yes - there’s a few templates that are great in that they let you edit a device, but they cannot currently pull back the current configuration, so in some ways, you’re editing blind when you make a change.

The evolution of the Electra One has made supporting a lot of different music devices worlds easier than any other controller platform I’ve worked with so far. Larger I/O system exclusive buffers would be the last* piece of the puzzle.

* I reserve the right to ask for more stuff after that. lol


it goes like this:

when sysex message is handled with Request / Response parser, it will just work transparently. That part is completed in beta version already. The missing bit is the exchange of long messages with the MIDI learn.

I just tested it with:

    "request": [],
    "responses": [
        "header": [
        "rules": [
            "parameterNumber": 1,
            "type": "cc7",
            "byte": 4093,
            "bitWidth": 7,
            "byteBitPosition": 0,
            "parameterBitPosition": 0

resulting in

8068708 processGeneralSysex: manufacturer 43
8068710 Midi::processSysex: matched response: responseId=0
8068710 ParameterMap::setValue: deviceId=1, type=1, parameterNumber=1, midiValue=0, origin=1
8068730 Midi::applyRulesValues: applying extraction rule: byte=4093, byteValue=86, extractedValue=86 to parameterNumber=1, type=cc7 resulting in parameterValue=86

So it parsed the 4093th byte just fine.

In Lua script the peak() function should reach any byte within the sysEx message too. I am considering adding buffered reads. That would speed processing.

I am partly back to working on the firmware again, for about a week now. I will make the latest version available soon.


Ever see this before?
This E1 has been acting weird ever since the a.14 update

1 Like

I seem to recognize this from other projects. The Electra is probably fully functional, isn’t it? So it’s like the addressing of the memory where the fonts are to be found that is empty or contains invalid data. Or are other phenomena present as well? Are the colors correct?

Is reloading the firmware any help?

1 Like

Hi @oldgearguy,

do the following. Pls note, it works on beta firmware only:

  1. Make sure you have the latest beta firmware (at least v3.0.-a.14)
  2. disconnect electra
  3. connect electra to the USB port
  4. press and hold the left-middle button when the boot up animation is active (this will format the internal SD card). The button must be pressed when the animation is in progress and it needs to be held down until the animation is completed.
  5. disconnect and connect electra again
  6. send enclosed sysex file to Electra Controller CTRL port ( (206.7 KB))
  7. disconnect and connect electra again

if you have done everything correctly, Electra should start up with all graphics assets recovered,

Thank you. Yes, now the graphics/text are restored and it properly goes through the boot sequence.

The remaining problem is actually the first problem I had – the E1 knobs do not change the values. I can press/hold on a screen control, the large slider appears and I can adjust the value that way, but the knobs do nothing.

please downgrade to 2.2 (the firmware is available on the website). Let me know if the knobs work with the stable version of the firmware. Thanks!

yes - 2.2 behaves as normal.

Please note - the other Electra One here has also been running the latest 3 beta and has been perfectly stable while I have been editing and using various templates.

ok, I will review this on beta.

There is another user who is experiencing similar issue. We have a conf call later today. I hope it will help me to understands what is happening there. I will share info on that / fix as soon as I know more. Thanks for reporting!

Attached is the Console app info for this controller. I tried reloading 3.0 a14 and same issue - knobs not working. I have/had the Alesis Micron Beta template and the Oberheim Cyclone (edited) templates as presets 1 and 6

1 Like

Here is the working hw unit info. Same 2 presets loaded in slots 1 and 8, although in the “right middle button” preset list, neither are showing up there (I do see them in the web beta controller management page)

So is the web beta editor really broken or is it just my configuration?
I tried using an Electra One on 3.0 a14 and connected to and the entire left panel is all messed up.

This was from Chrome on a Windows 10 box. All previous edits have been done from Chrome on a Mac Mini.

1 Like

I am currently busy with making bigger changes to beta. These changes are related to new features of the firmware. There might be moments when beta is affected by that.

I have just updated both beta website and the beta firmware so that they work nicely together. This means that 3.0-a.20 is available on Zipped file is attached below.

3.0-a.20 is collection of changes that I made recently, amongst others they are:

  1. added support for new types of midi messages. poly and channel aftertouch, pitchbend, song position messages types were added. This comes with an adjustment of the web interface too. A new way is that one picks the type of control (fader, list, pad, envelope) and the message type is selected in the Control properties.

  1. controls use 24-bit RGB colours. ie. the limitation of 6 fixed colours is removed. Note, electra internally uses 16-bit RGB565 scheme, therefore conversion affects the final colour. The web editor provides now larger selection of colours. I am heading towards having number of colour sets compatible with other software (Electra, Ableton, Bitwig, Novation components, etc).


  1. control variants are now supported. It is possible to pick different visual styles of given type of control. Faders come in two flavours: thick and thin. Lists can be either the lists with dots or a button styly type (tap switches between values). Note, the dial style fader is not accessible yet - not easy to fit the graphics in the tight space of the control…


  1. control modes are supported now. For pads, momentary and toggle (it was already there). For faders unipolar and bipolar operation can be selected.


  1. An option to specify if NRPN messages send the RPN reset bytes has been added.


  1. incoming SysEx and SysEx MIDI learn support virtually unlimited messages. I tested that with 4k TX7 bank transfers. It works, although the web editor needs quite some time to process and display long midi-learnt messages.

  2. MIDI notifications are sent on page, preset, bank switches. There are more additions to the SysEx API. More info is available at SysEx implementation | Electra One Documentation

The Ableton integration (developed by @jhh) seems to work nicely with this firmware.

I still know about number of glitches that need doing. Above has been tested on both MacOS X and Windows and seems to be fairly stable. The website app needs doing too.

The firmware file for those who have troubles with update on the web: (316.6 KB)


Is it possible to like a post more than once? :grin:

Amazing list of updates. Thank you so much for balancing work and life despite the difficulties.


Yep, Martin,

great work and thank you. I’ll be testing these features asap

1 Like

quick question - I want to call control:setColor(), but to do that, I thought I needed to get the control object and to do that I need to call controls.get(ID) where ID = the control ID.

I have 1 control on screen in the first position, yet controls.get(1) is failing with the message “Control does not exist”

pls reload the preset now. I am working / testing new control references now.

lol – hard to keep up with you Martin.

well, I can see that control:setColor() still accepts the predefined colours only. I will change it to RGB format.