How do you save snapshots?

Hi, new Electra One owner here. So far I love it, but I can’t figure out how to save a snapshot! When I go to the snaps menu and press save, and then select a empty slot, it goes back to the control page but doesn’t save the snapshot. Am I doing something wrong?

285874 changeSnapshotLambda: saveMode=2, filename=ctrlv2/s006/s0060000.snp
285889 entry: deviceI=1, type=1, parameterNumber=1, midiValue=0
285908 write: cannot seek: 4, max size=0
285908 displayPage: page shown: page=0, controlSetId=-1
285910 ElectraApp::handleElectraSysex: sysex received: command=2, parameter=5
285946 ElectraApp::handleElectraSysex: list of snapshots sysex sent to the host

looks like you are loading instead of saving.
not sure if i remember it correctly but when selecting save, then you select a slot to save it on.

Hi @dcam, have you managed to save any snapshot? And can you try with a different preset? The steps you are taking, ie. selecting a “SAVE” action and that tapping a slot is correct.

The cannot seek message indicates an uninitialized internal snapshot file. The fix for that problem is on the way as well as snapshot management integrated to the web application.

I haven’t got a snapshot to save yet. Yesterday I tried creating a new preset with one cc and saving a snapshot, and using two community presets but had no luck with any of them saving the snapshot.

Check your firmware version?
I tried saving snaps on my Korg NTS1 preset yesterday (I didn’t use this functionality before ) with the Electra One on firmware 2.1.7 and this works.

Yes, mine came with 2.17. Apparently it’s a bug with initialization. Martin is working on a fix. :slight_smile:


@dcam, firmware 2.2 should resolve your issue. At least if my assumption was correct. Please let me know if it works now. Thanks!

Database is broken

22:01:43.901		ElectraApp::handleElectraSysex: sysex received: command=1, parameter=2, byte1=123
22:01:43.901		ElectraApp::handleElectraSysex: unknown sysex request
22:02:01.262		displayMenuWindow: menu window shown
22:02:01.265		displayHintWindow: hint window shown
22:02:01.298		Database::open: File is broken: file='ctrlv2/snaps/YlrfBLjblreKmIUvaqIC/snapshot.db'
22:02:01.302		SnapsWindow::paint: cannot open the snapshot database
22:02:01.442		displayMenuWindow: menu window shown
22:02:01.459		Database::open: File is broken: file='ctrlv2/snaps/YlrfBLjblreKmIUvaqIC/snapshot.db'
22:02:01.460		SnapsWindow::paint: cannot open the snapshot database
1 Like

Ok, we’re getting closer :slight_smile: I am leaving for the Superbooth tomorrow. I will continue working on that as soon as I am back / Sunday.