None of the presets can fetch patch information from Synths

I’m using a Conductive labs MRCC as a midi router for everything, and my Electra One is set up to send midi to each of the ports with synths, as well as recieve midi back from them all there. I’ve edited the presets so the devices use the correct midi channels I’ve set on all my external synths, but whenever I try to request a patch from a synth using it’s preset or edit the parameters of my synths nothing happens. Is there something obvious I’m missing? it seems like the controller just can’t actually communicate with any of them.

1 Like

Hi, I’d suggest connecting one of the synths directly first. Just to see if that works without the router.

Other messages, such as note on/off, are processed ok? I do remember I heard about some limitations on sysex processing on MRCC routers. There was (is) a limit on the maximum message size. @joris.roling, @oldgearguy might know. Also, I found this online: Does MRCC Route MIDI SysEx Messages? |. What firmware version do you run on your router?

Let us know if direct connection work. Thx.

1 Like

I sold the MRCC because of it’s inconsistent SysEx routing. If I remember correctly, the USB ports never routed SysEx, and the upper DIN (7-12) didn’t either, something like that.

I am now very happy with a iConnectivity mioXL + Blokas Midihub.

A number of questions/suggestions.

First - definitely update the MRCC to the latest OS version.
Next - how is the Electra One hooked into the MRCC? USB or DIN?
Next - the target synths - are they connected to the MRCC via USB or DIN?

I’ve been using the Electra One and MRCC successfully for a while configured as follows:

Electra One ↔ computer via USB for editing and sending presets to the Electra One.
Electra One ↔ MRCC via DIN to communicate to various devices (also connected via DIN)

I don’t remember if I have any synths/fx that connect to the MRCC via USB and are edited with the Electra One.

However, I do know the above configuration works for sure.

I tried a direct link between my Alpha Juno 1 and the Electra using the MKS-50 preset but also had no luck there. I did edit a copy of the MKS-50 preset to look for midi channel 2 and set my Alpha Juno to use that same midi channel.

The devices appear to be able to communicate because I was able to use the midi learn function to create a new parameter in the MKS-50 preset for pulse wave shape, and it was able to change that parameter on the synth, but none of the other parameters that came with the preset seem to work, and requesting a patch from the synth didn’t update any of them.

1 Like

All of my devices are connected via DIN in the MRCC except my Korg Opsix, and the in/out ports of the Electra are hooked up via DIN as well. The Electra is hooked up to my computer via USB and is able to control Ableton that way without a hitch thankfully.

I am merging 5 midi inputs from the synths to the Electra plus sending midi to 5 different outputs via the MRCC. I’ve tried to make sure my control presets and synths match midi channel but it’s a touch hard to tell if I’ve done that completely successfully.

Also MRCC is updated to the latest Firmware version. I’m routing midi note data from Ableton to the hardware synths with it, but Im not routing any midi back to the PC USB port from the synths.

1 Like

I tried a direct link between my Alpha Juno 1 and the Electra using the MKS-50 preset but also had no luck there. I did edit a copy of the MKS-50 preset to look for midi channel 2 and set my Alpha Juno to use that same midi channel.

Be careful when using a preset with Sysex meant for a specific model (such as MKS-50) and expecting it to work for another model (such as Alpha Juno 1). I haven’t done any investigations in this SysEx of Roland. It could work without tweaking, but usually it doesn’t. There might be slight changes to the SysEx header to apply, to make the right model respond.

@martin I recall you built a preset for the MKS-50. Is it compatible with the Alpha Juno 1 without changing anything to its header?

OK - the first and last parts of your message is very good. That is a known good working configuration, so it must be something else.

Please clarify the middle part of your message - when you say ‘merging’ do you mean you have routes set up on the MRCC between the Electra and all 5 devices? If so, what happens if you disable 4 of those routes and only have 1 active route between Electra and a single synth?

In theory, sysex message requests should only be recognized and acted on by the target synth, but other things like CC or NRPN or note messages could cause multiple synths to trigger and respond, depending on the channel/port configurations.

Also - repeat that MIDI Learn test with the MRCC back in the middle of things.
Finally - if you have a MIDI controller/keyboard hooked up, unplug the Electra and plug the MIDI keyboard into those same ports with the same original routes and see if you can trigger notes on your other synths.

Theoretically, this shouldn’t be an issue. If I recall most of the hardware programmers made by Roland we’re cross-compatible between the keyboard and rack versions of equivalent synth engines (in this case the PG-300 worked with the Alpha Juno 1, 2, and MKS-50). It’s possible there might be some differences between how those function and how the preset on the Electra does that would mean a major difference, but the fact that I’m also experiencing the issue with other synths makes me feel like it’s more likely to be something else.

you’re correct, I do have the Electra and 5 hardware synths routed to each other using the MRCC routing options. I mentioned merging just because the 5 midi DIN inputs on the MRCC are all routed to send to a single midi output back to the Electra.

I’m going to try these suggestions later tonight, but as a fellow MRCC owner, I wanted to ask if you thought using the port-routing modifiers to force the correct midi channel onto each routing would be a good idea or not?

I guess it depends on how you normally do things. The idea of setting up “my route from port 1 to port 7 always talks on MIDI channel 7” seems like it will make life easier as long as you’re not changing things around too much.

Since I tend to have a handful of devices that talk (MIDI keyboard, hw sequencers, Electra) and more listeners and I tend to be swapping hardware in and out, it makes sense for my setup to do as little as possible inside the MRCC so that it mostly is working as just a smart pipe handling merging and splitting.

I’ve tried to use some of the modifiers from time to time with mixed results (and no need to go into a public discussion here).

Also, I tend to start up my MRCCs with the routes mostly empty and just quickly set up the ones I need at any given time, but again - my use case may not match yours.

Suggestions if you haven’t done so yet - join the MRCC forum on the Conductive Labs site and throw some questions out there. Jesse is a great help and he’s usually happy to set up a Zoom call or FaceTime and work with you directly to get things sorted out in real time.

1 Like

For sure, Ideally, I want the MRCC/Electra combo to just always be set and ready to go with all my gear hooked up at once without having to switch stuff out, so a bit different.

Update on trying the midi learn function while routed through the MRCC; I was able to midi learn a SYSEX parameter from the Alpha Juno and add it into a new blank electra preset, but it seems like the Electra can’t send that parameter back to the synth through the MRCC, whereas when it was plugged directly it could do so.

EDIT: also just tried sending midi notes from the alpha juno to another synth routed through the MRCC and that seems to work fine.

One last thought – I know in the past the MRCC did not like sending/receiving sysex from ports higher than 6. Is the gear you’re trying to talk to plugged into MRCC outputs higher than 6 (7-12 on the MRCC output side)?

Have you verified your MRCC is on the latest OS update? It’s available on the website (I think the official one is the latest) or in their beta section of their forum. Unfortunately, I cannot connect to the Conductive Labs site during the day so I can’t give you a direct link.

I’ll try to carve out time this afternoon to test… Looking at my setup docs, it seems that any gear I have that needs the Electra One (so far) is plugged into MRCC ports 6 or lower.

Another random bit – if you have a synth that can do an arpeggiation (with Hold) or it’s all close enough for you to watch – have the synth playing some notes. Now look at the main MRCC display and see if one or more arrows on the left are lighting up to indicate incoming MIDI data. Verify it’s on the MRCC port you expect. If you’re not seeing any arrows light up it means the MRCC is not seeing data coming out of that synth.

Hmm the Electra is recieving midi back from port 8 and one of the synths is hooked up to port 7, The Electra is also sending midi to input 6, which is a 3.5mm midi port only. I’ll swap these around and see if it makes a difference.

If you have OS version v1.1.071 (go to the last page and verify that), it has this:

So it should be working and likely there is some routing issues instead (likely - not guaranteed)
It still could be a real bug, but I think that sysex is more stable now than before.


  1. Major overhaul of System Exclusive (SysEx) message handling. MRCC should be able to handle any length data to all possible out ports including MRCC to MRCC & MRCC to Remote 7. Please note: It is possible to overrun the MRCC’s internal buffers when sending large SysEx files from very fast USB to very slow 5 pin DIN outputs. The sending software should throttle the speed it sends SysEx. Also note, if sending large SysEx files, be sure to temporarily turn off any other MIDI data sources. Once the internal buffers are full, MRCC will block MIDI data on merged inputs, but better chance of success if its not having to handle clock and other messages while the large transfer is happening.

Ok bit of an update; I tried a few more presets in addition to the Alpha Juno one and am running into similar issues, but I’ve discovered a new behavior with the alpha Juno.

When I had that synth plugged directly into the Electra, I was able to use midi learn to create a parameter in the preset editor for pulse wave shape, and then the Electra was able to send that control parameter back to the synth when I sent it into the hardware. Routed through the MRCC now, I can still use midi learn to create the same parameter, but now when I send it to the hardware, adjusting that parameter with the Electra will only send a minimum value out to the synth for that parameter, even though the Electra sees that there should be a total of four values possible. For pulse wave shape this has the effect of turning the pulse wave off, and I have to adjust the parameter on the synth itself to make any changes.

Other issues from trying other presets; I tried using one for the Yamaha TX81Z (which I’ve loaded in a preset slot on my Electra but the patch has seemed to have disappeared from the public presets library) but the preset seems to not be able to control the hardware unit and can’t request patch information. I’ve also tried using the Waldorf Micro Q preset, but that one just causes my Electra to Freeze as soon as I try to adjust any parameters in it, so I can’t tell if it will affect the hardware unit or not.

A random thought - might be a MIDI loop causing that issue. With routers it’s often all too easy to get a loop going. Test it in isolation - since the control is working on the E1, unplug the cable going to the E1 input and see if that helps.

I tried this and nothing seems to have changed with the behavior of the test preset I was working on. After using the midi learn function to create a parameter I disconnected the cable sending midi back to the Electra hardware, but adjusting the parameter still set the value to minimum no matter what position the Electra said it should be.

I did notice that when using the midi learn function, the Electra didn’t automatically create a parameter with the full range of the sysex command for changing the pulse wave shape until I used the dial on the Alpha Juno to scroll through all of the possible options (to clarify, as soon as I moved the dial one position, the parameter in the Electra preset editor showed two possible values, then three, four, and so on until i moved through the full range of the control on the synth itself.)

Do I need to edit anything else in the preset editor to make sure that the correct sysex messages are being sent back to the synth? the way it’s behaving currently leads me to believe sysex is being passed through the MRCC from the Electra to the synth, since if I set the pulse wave control to something other than default on the synth itself, changing the parameter using the Electra will set the value back to default rather than just doing nothing. To me, this seems like the error happened somewhere in the midi learn function, and all 5 positions for that parameter are sending the default sysex message instead of the proper message for each wave shape.

I also realize that I havent tried a parameter that uses CC data yet, and I want to see if I have more success with that kind of control or not. I’ll keep updating about it soon!

Definitely do try out a CC in both directions before implementing Sysex.
Have you checked if the syntax for a parameter change via SysEx is the same in both directions?
Is the synth configured to receive SysEx?

Do you have a monitoring tool that allows you to see the MIDI messages sent back an forth?

Ok, finally some progress!

I was able to use midi learn to create a parameter for the filter cutoff of my Minilogue XD module, and when sent to a blank preset space I’ve got bi-directional control between the physical knob on the synth and the control parameter on the Electra, all while running through my MRCC. Interestingly, moving the cutoff knob in learn mode populated two different controls (Param 43 with a full 0-127 range and param 63 with a 0-7 range, but I used parameter 43 for the electra preset I just made which worked)

So now the question is; why is it that the MRCC is having such a difficult time allowing SYSEX information to pass from the Electra to my hardware synths, but it can apparently receive that information and pass it to the Electra just fine?

1 Like