Roland MKS-80

Preset for the Super Jupiter, please set the synth to:

  • Midi Channel 1
  • Midi Function III

For the time being just hook up the Midi Out of the E1 to the Midi in on the MKS, as I don’t have bi directional communication yet.

ROLAND MKS-80.epr (27.3 KB)


Wow, cannot check it out till next Sunday, but thank you so much!
Will definitely try it out and give feedback :blush::+1:


I have two remarks:

  • Lower Tone and Upper Tone have the same Parameter ID, I am not sure if it is correct
  • You use text labels to offset the display value from the midi value that is being sent. You can do the same by setting the display min/max and map it to appropriate midi min/max. In your case, following should do the trick: MIN DISPLAY VALUE: 11, MAX DISPLAY VALUE: 88, MIN MIDI VALUE: 0, MAX MIDI VALUE: 63. Your solution works fine, but using display/midi value mapping as I suggest that is way more efficient.

:slight_smile: thanks it was fun to work on, fixed the parameter numbers, had that issue in a couple of other areas too. Completely forgot the lower tone’s edit section, its a simple copy paste of the upper’s pages though, with a different midi channel i believe, so shouldn’t take too long

I also believe my bidirectional issue was because I don’t have a checksum in there, need to include that too.

Thanks for the heads up on offsetting the display value, will give it a go when I update the the preset

Updated version with the parameter ids all organized into their respective groups, the lower tone section has now been added, as well as the use of offset display values. Hope to include some parsing in the near future.

ROLAND MKS-80.epr (35.5 KB)

1 Like

Works great! :slightly_smiling_face: Thank you!
Does anybody know why ALL functions work when directly attached to the MKS80, but the “Global” stuff (patch selection etc), does not when going thru Ableton?

in addition to my last question: How would I send a system common message? My mks80 needs to be tuned quite often and I want to do it from the electra. I found out the the tune request is :

1111 0110

or alternatively hex: F6
Can I just put that into the sysex field even though it’s NOT sysex?

not in front of the set up right now, but ya Id setup a fader to send SysEx and input the following line in the custom data window
“type”: “value”

and in your min midi value input 0 and max midi value input 1 ( taking a guess here)

Hope that helps

1 Like

@markus.schloesser @razmusen you should not not put that into the sysex message. Even though it might work on some devices, it is not a correct way to do so. I will add this on to my todo. I do see two ways to go:

  • add more types of messages (including F6)
  • make it possible to send “freestyle” bytes. That would be similar to sysex data, but users could enter any sequence of bytes

I am impartial as to how to implement this, as long as it works :slight_smile:
Do you know, when you will be able to implement this?
@martin 2 questions:

  1. what might happen if I were to use the (incorrect) sysex field?
  2. any idea w re to the Ableton problem?

Ya it would be great to have a way to just send a one off command

  1. you can try to include F6 in sysex mesage and try that. It depends on the receiving device if it will accepet the message.

  2. Just mentioned in other thread that I am not good with Ableton. I will install it and try to reproduce it.


Hey just got a chance to try out the electra one going through ableton and then back out again and was monitoring it with a program Ive used for ages called midi monitor, as I dont have the MKS hooked up right now.

Im on a mac, btw.

So all the parameters including the global ones were being sent out of ableton correctly, and registering in midi monitor

Edit: I didnt want to half-ass the trouble shooting, so I hooked up the MKS and it is indeed receiving all parameters including the global ones.

So in ableton, Ive tried both record arming the track, as well as monitoring the track without the record enabled, and in both cases all data is being received by the MKS

Could you give us some more info on your set up, computers OS, type of midi interface, and midi set up within ableton? maybe I can try and help you track down the issue

One last question, could you have by chance altered anything on the editor before you sent it to the Electra?

Hi Razmusen,
thanks so much for testing!
I’ve tried to narrow it down:
What works on the global page: Glide, Mode, Octave (and of course the other pages)
What doesn’t work: Patch

my system: Windows 10 x64, 1909, Live 10, iConnectivity Mio10

If I changed something, it would have been Labels or position only.

Also I tried to implement the tune request. First the editor didn’t accept the data as valid, because the forum software changed the quotation marks to formatted ones. After I had fixed that, it still didn’t work. The mks80 doesn’t receive anything. Do I need to do the whole “41”, “36”, “00”, “20”, “30”, “01” for the tune request as well?
Also, looking at your preset, I see that “glide” (which works) does have the proper sysex 41… whereas “patch” does not. Could that be the problem?
I attached the preset hereROLAND MKS-80 Tune Test.epr (35.7 KB)

Hey, no worries my pleasure, as soon as I read your post the one thing that sticks out is the iconnectivity mio10, Ive come across users on other forums with numerous issues with regards to that brand of midi interface.

I know it has a routing software called aura or aurora or something like that, might be worth taking a look in that routing application to see if anything is being filtered.

If u have another midi IO handy, that would narrow down the issue, i was using a cheapo 1x1 usb straight to midi plug, going from the mac straight to the unit, with the E1’s messages being sent through ableton live.

In that scenario all the messages were being sent including the patch select and upper and lower tone select.

tested it with Midi-OX (the midi monitor of Windows) to really see what’s going on.

  1. “Patch change” isn’t even seen by the mio10 as midi, neither is tune request. All other global parameters are “seen” and recognized on the mks80 via midi message blinking (even though upper and lower do not work). I do see the values being sent in midi-ox.
  2. also tested with the Midi interface of the RME UFX+. No change with the exception, that patch and tune request are seen on the UFX+ as midi, but also does not work on the mks80.
  3. Wasn’t aware that the mio has problems. Do you have a link for that? All I have seen is, that even for massive sysex, the mios are fine.
  4. checked the mio config via auracle and iconfig, no filter is set, except for active sensing. But doesn’t matter anyway as RME also doesn’t work (see 2.)
  5. in your tests, did you use the USB port of the Electra or the Midi ports? (I’m using USB). If your answer is that you used the Midi ports, then could you please try again with the USB port?
  6. Everything did work when I used the midi port of the Electra, Patch Selection AND even the “Tune Request”
    Seems the problem is either the USB Midi driver for Windows or the USB port of the Electra
    @martin any idea?

Will l check later, what goes thru the midi port of the Electra with a second computer.
One thing I noticed was that even though I only input “F6” for tune request, what midi-ox showed was “F0 F6” and (but nothing more), same for the patch select where there was a “F0” added at the beginning

Hi Markus, this is what I was afraid of. the F0h is a start of the SysEx message. Electra puts it there because you are using the SysEx field. It also adds F7h at the end - it marks the end of the SysEx message. This means that when you insert F6h to a SysEx message, it will actually create a 3 byte message F0h F6h F7h. Because this is not correct midi message, it depends on each device what it will do with it.

I just looked at the MKS-80 preset, the issue of patch change is the very same. the C0h, which is a Program change on channel 0 message is inserted to a SysEx message. That is basically an invalid message and different gear might handle that differently.

The new firmware I am currently testing with a group of users supports more types of midi messages (note on/off, program changes, start, stop). I will add the Tune request there too. That will fix both issues you are having with the preset.

Hi Martin,
thanks for looking into this!
BUT: the first image is the Elektra connected via Midi, the second is via USB. Both directly going into Midi-OX. (1. 2 tune requests, 2. patch changes, 3. Upper Tone changes)
In the first case, Midi-OX correctly detects the kind of message, and subsequently it works with the mks80. In the second Midi-OX it does not. Why is that? :thinking:
So you see, something is weird.

I still agree with you w re to System Common as an additional input format, but this doesn’t seem to be the problem here, or does it?


Hey no updates on the MKS from my side, but wanted to clarify the post I made about user issues with the iconnectivity.

The issues i had been coming across, on gearslutz, were regarding setting up a midi network on windows, and with previous versions of the auracle routing software, none that i could find were actaully complaints on transmitting sysex messages, so you should be good on that end.

1 Like