Set display brightness to 0 ... now it's at 0. Always [SOLVED]


I managed to “brick” my device within the first 5 minutes, sadly. I was happy to find the display brightness slider – set it to 0 and no Boot Logo or anything was being shown ever again. Tried Hard Reset … didn’t fix it.

Any ideas @martin ?


What were you doing just before it bricked?

The Hard Reset (holding left middle during power up) didn’t help?

as I said … it’s not bricked as in bricked - the display brightness is just set to 0. Last action: Setting display brightness to 0 :wink: and then blindly tried to set it to another value … but sadly I couldn’t set it to another value afterwards.

Tried to press the left middle sidebutton while booting - display is still off.

Edit: SOLVED by technobear in another forum:

I quote him for the steps it took to fix it:


@Martin , perhaps a couple of small changes for future release

  • don’t allow brightness slider to be set too low
  • when restoring runtime settings, have a minimum brightness… just in case.
  • one of the reset button sequences , should reset properties that are stored in eeprom?
    (perhaps in removeAppFiles) ,. or whatever its called)

btw: the above is kind of a ‘fortunate’ bug :slight_smile:
Id say the sleep wakeup should restore to runtimeinfo::brightness, whereas it restores to full brightness.
perhaps if the above fixes are in place, this fortunate bug could be fixed?


Is it actually documented somewhere? I seem to be able to invoke it by accident.

First off, thanks @thetechnobear for helping. I was away from the computer today.

Both valid points. Will implement that.

  • one of the reset button sequences , should reset properties that are stored in eeprom?
    (perhaps in removeAppFiles) ,. or whatever its called)

The hard-reset resets the contents of the eeprom including the brightness settings. It should recover from to normal brightness. Of course, this is not an excuse for allowing to set the the brightness to 0 :slight_smile:

yup, you will find that at the bottom of Hardware overview | Electra One Documentation.


I felt a bit silly so I checked that on my 2.3 unit. It does not go to the full dark when I move the slider all the way to the left. I am not in the workshop but I will check on 2.4 when I am back there. The LCDs should be exactly the same for all revisions. I will keep you updated.

I’ve got HW version 2.4 on my unit and I can also confirm the display turns black if dragging the slider to the far left. In fact, it turns black earlier, around after 10% from the left endpoint. Also, the brightness doesn’t increase any more after you’ve reached around 45% when sliding to the right.

Fix is available in just released firmware 2.1.4. It prevents the screen from going completely dark on hardware 2.4.