Standalone black screen/buttons [SOLVED]

Hi everyone, just received my E1.

Is there a specific procedure for using the E1 in standalone mode ?

When I connect it to a laptop, everything seems fine. When connecting to usb power only, E1 shows boot screen then stays black forever.

Another question, the middle right button is way higher than the other and does not have the same feeling as the others, less clicky and for 90% of its course thare seems to be absolutely no resistance. If I press on the bottom or top one it moves up more…

Is that expected and a normal behaviour ?

Thanks a lot.


Sorry to see the button issue.

The USB adapter issue can be fixed - it was actually fixed in the 0.9.* line of firmware already. I applied the same fix to the new firmware, but I am not sure if you have that version. Will check that for you.

The button. It feels like that your Electra had a bit of hard time on the way. It is not OK that the button sticks out like that. I test all Electras prior to shipping. I would not let this go out.

The buttons are one piece of rubber with two cylinders on the bottom that are fitted to the holes in the PCB. They are glued to the PCB on the sides. I assume the cylinders got out of their holes during the shipping.

If you want try to fiddle a little bit with the middle button, or gently lift it up a bit and fiddle. With a bit of luck, the cylinders will “jump back in”. If you do not feel comfortable with that, let me know, and I will arrange a replacement unit for you.



Thanks Martin,

fiddling FTW !

The current firmware version at startup is 1.0.9.

I’m going to upgrade to last rev and i’ll report back.

Very happy to hear that! I am always a bit stressed when I see something like that. Btw we are awaiting new packing sets with polystyrene inserts The delivery gets delayed due to covid again. I hope it will prevent issues like this in near future.

Upgraded to 1.1, issue solved !

Thanks a lot for your fast replies !

1 Like