Unit not powering on

Unit is not powering on. Checking through ElectraOneConsole, nothing shows up in port configuration when connected via USB. I have tried the firmware recovery process of a hard reset, then plugging into the computer with the Console open, and holding the reset for 10+ seconds, but still, nothing shows up, and the screen does not power on. I have tried this on two computers on which Electra One used to work, and with multiple USB cables. My ElectraOne has stayed in the same place on my studio desk since purchasing it.

Please advise.

1 Like

Reply available on PM

Having the same experience.


From what I read in your other posts it looks like that the firmware update did not go ok. It is quite easy to fix. I can send you instructions via PM or we can have a videocall (ideally on Saturday). Let me know which way you prefer. Thanks!


If you can send instructions by PM, I can certainly try to revive it on my own — if that doesn’t work, a call on Saturday would be great. Thanks so much.

I have the same issue, E1 not turning on anymore.
This happened while updating to beta 3.0. The update stopped at 84%, I waited 5min, E1 was still on but unresponsive. I disconnected it and since then it does not turn on. If I could get the instructions to get it to work again that would be great, PM works. Thanks a lot!

1 Like

There are two ways to fix it. One in the browser and the other in using the Electra One console app.


  1. disconnect Electra from the computer
  2. quit the browser (I mean to really stop the browser application so that no other windows are running)
  3. open the browser and go to the app.electra.one or beta.electra.one
  4. connect Electra to the computer
  5. click the recessed Update button on the bank panel of the controller (the one next to the round MIDI IO connectors)
  6. go to the Controller :: Update firmware section and hit the update button. It should run ok.

in the Electra One console app:

  1. disconnect Electra from the computer
  2. download the latest firmware from Controller firmware page
  3. unzip the file and have it ready for later
  4. start the Electra One console app
  5. click the recessed Update button on the bank panel of the controller (the one next to the round MIDI IO connectors). The Electra One console will indicate that the controller switched to the Update mode.
  6. click the Update button in the Electra One console app and choose the firmware file you downloaded earlier.

If above does not help, pls ping me on PM

1 Like

Thank you @martin !
With the Electra console it worked all good :))
I first tried the browser solution but i had the same error: update progress goes from 0% to 84% in ms and freezes there.