[3.4.0/3.4.6] MIDI callbacks do not get called


Today I received my brand new E1 mk2.

I noticed that the MIDI callbacks do not seem to get called.

I initially noticed this on the 3.4.0 firmware which was preinstalled on my unit when I first turned it on. I also tried the current beta version 3.4.6 which made no difference.

In order to try to exclude user error I made this very minimal preset: Electra One App

Here are the steps to reproduce:

  1. Connect E1 to computer
  2. Open preset in editor and send it to E1
  4. Select the first MIDI port of the E1
  5. Send cc 1 127
  6. Observe that the pad on the E1 switches to the on position
  7. Observe the text started in the bottom right corner

I am calling info.setText("message") in my callback and I would expect the started text to change to message on the bottom right corner, but that doesn’t happen.

If I set the log level to Trace then I can see the following lines printed as I send in the CC messages:

21:31:16.365 ElectraMidi: processMidi: Control change midi message: parameter=X, value=Y

X and Y correspond to the parameter number and values that I am sending in.

Just as a sanity check, un-comment line 4 and observe as the text in the corner changes to counter N where N is increased by one every second.

It would be nice if others could try to reproduce this and report back with the results.

What do your callbacks do?

Are you turning on the Electra before other devices that connect to it?

The preset is specifically tailored for reproducing my issue, therefore the only connection that is needed is to the computer.

I updated my original question to include what I’m doing in the callback.

I replicated that. It is related to onMessage(). Other callbacks seems to work ok. But I will double check everything.

1 Like

I first noticed this via the active sensing callback but I haven’t tried it again on the beta firmware.