Ableton Live MIDI Remote Script / Control Surface

This is quite amazing what you did there with your scripts.
Thank you for gifting us this!

2 Likes

I recently dived deep into @jhh’s work on this. I must admit I am truly amazed much work was done on that and how complex it is. Not mentioning that @jhh documented everything and even added a general tutorial on Ableton’s remote scripts.

It all helped me a lot to integrate it better to the upcoming firmware 3.0. By gaining this extra knowledge and having a well written remote script in place, we can really take things much further.

5 Likes

Thanks.

Please note I just pushed a major update out to GitHub to support the 3.0 version of the firmware. This version is NOT compatible with version 2.0 of the firmware.

1 Like

@jhh Regarding the 14-bit CCs. Electra recognizes them for CC 00 … 31. That is what MIDI standard says. It is quite easy to change this for CC 00 … 96. But will that work with Ableton?

@Martin just tried, but at least when doing MIDI learn it ‘learns’ the wrong CC-number: not eg. 0x40 but 0x60. So don’t bother - always best to stick to the standard, even if the standard is stupid :wink:

Or even better: I was always thought to be forgiving for input and strict for output, so allow incoming 14 bit CC’s in the second block (0x40-0x7F) but never send them out.

1 Like

Big Thanks for the Script! :pray:

I manage to solve the “Script thing” with Ableton. It didn’t work the first time, but now it works, only “prev. track / next track” doesn’t work. what could be the reason for this?

1 Like

As I already wrote, the ableton srcipt works perfectly, only the “prev. page”, “next page” “buttons” do not, and it would be very important that this also works.
This is the error message in Ableton, at the bottom, in the small section:
Control surtace 1 (ElectraUne) > E1 managing tracks 14 - 1¢

Could someone help me? :pray:

Error message

Strange. You say the message reads : Control surface 1 (ElectraOne) > E1 managing tracks 14 - 18". That should not happen (it should start by managing tracks 1 - 5). When you start Ableton and open a new Live set, what is the first message being displayed? And what tracks does the mixer actually control?

Thanks!
With new project:
Control surface 1 (ElectraOne) > E1 managing tracks 1-5
But it doesn’t work either.

“something happened”, now it works perfectly.
:pray:

1 Like

Hi @jhh,
is there any easy way to remove “Device On” button from Plugin Devices and Audio Effect Racks, please?

Unfortunately, the Script doesn’t work for me for some reason. if I were to use the Script, the E1 immediately goes “crazy”, the display does not respond and random parameters are switched on/off, which is “interesting” that after such a “crazy” I turn off the E1, reinstall the Firmware, but however, this state remains. The E1 must be switched off for at least 12 hours, only after that it works fine again. It’s a shame, because it would be very useful for me anyway…, but I don’t even dare to try it anymore, because then I can’t use the E1.

Hi. I would have to add a configuration option to the script for that. Added it to my todo list.

1 Like

That is indeed very strange behaviour. What version of the script and what version of firmware are you using? (The latest version of the script on Github expects the 3.0 beta version of the firmware, which is not ideal as it is incomplete).

I use 2.2 Fw.
the E1 also does not work well with the 3 Firmware. the settings are not displayed, etc

Version 3 of the firmware is beta, a lot of things do not work. Eg switching presets is also not possible. This is not something I can fix.

I know, is a beta
could you send me a Script folder for the 2.2 Fw that simply needs to be copied into the Ableton Live Script folder?

Hm… that’s not going to be easy…

Does anybody else notice strange/bad behaviour when running the most recent version of the remote script on the 2.2 firmware?

as I already wrote, if you start Ableton with E1 as “control surface”, using the script, this happens immediately, which can be seen in 2 videos.
an important question…
I already wrote that after “this happens”, no matter how much I turn off the E1, no matter how much I reinstall the 2.2 FW, reset, etc… nothing helps, this “crazy state” remains.
It would have been important for me to be able to use it last night, but I was careless and missed “switching off” the script ,…at E1 it got crazy,…unfortunately I couldn’t use it all evening. first I turned it off, waited 2 hours, just in case…, but after 2 hours of being turned off, I turned it on, and the same “crazy state” was still there.
I turned it on this morning and it works perfectly.
it would be very good to know that if “this happens”, how can “this condition” be eliminated?
just by waiting 12+ hours?
This:

I tried the whole thing again from the beginning…
currently it works almost perfectly, the only problem with it is that when i switch to the the mixer preset, it does not see the “current values”. the control works, I can switch the tracks on/off, all “controllers” control Ableton, but in this case, if e.g. I want to set the volume on one track, first it jumps to zero, and that’s not good. I switch to another preset, control what I need, then switch back to the mixer preset, and everything is back to zero. what could be the reason for this?