Ableton Live MIDI Remote Script / Control Surface

Hmmm I loaded again the ableton session and it does not work. Needed to switch to port 3 to see a device but then switched it back my e.one crached.
The mixer template never showed.

If I am correct the electra one should be able to recieve sysex templates on all ports.
It strange as last session it seemed to work and now not.

@martin does * firmware v2.2 listen to sysex templates on all ports?

1 Like

As of 2.2 it the Electra SysEx commands are supported on all ports. The responses where, however, sent back on the CTRL port. That is the reason why MidiPipe is needed. It take care of the responses only. This has been resolved in beta firmware, ie. upcoming 3.0.

I kind of cannot imagine how the configuration you had on the screenshot could work :slight_smile: Possibly with some older version of @jhh’s scripts? Anyways, to get stable functionality the MidiPipe is required with 2.2.

Yeah maybe I was to fast in my judgement .
So its more sure after your update.
So it could not have worked. sorry for that.

You can ONLY do that, if your midi interface has dedicated drivers which feature multi-client capability and the E1 is connected via din midi. So for example from iconnectivity, erm or rme. The Windows inbuilt usbmidi drivers are not multi client capable, that’s why when you have the E1 connected via USB, you cannot have 2 applications accessing the E1.
For that you need loopbe. So the applications both go to loopbe virtual midi connection 1 IN and only loopbe accesses the physical usbmidi port OUT.

1 Like

Thank you fort your answer!
I will dig into it this weekend.
I do have an RME and a mio10.
I opened Loopbe30 (I couldn’t get an interface with loopbe1), but I will need to dig into the manual.

Not a problem! I just wouldn’t have accepted it works fort one and not for me lol!

I’m assuming I would have to disable the E1 USB to Ableton, connected via midi din in Ableton and USB into the editor…?

If you have the e1 directly connected to the pc, then you need to disable it in Live.
If the e1 is connected via the Mio (either USB or din midi) , then you don’t.

Last question, are you able to control the editor when E1 is connected to the Mio via USB? (somehow I assume you have one, but maybe not). Unless I haven’t set up a setting right, I’m never able to use editors and such unless the device is plugged to the PC directly, not via Mio.

1 Like

This doesn’t work for me either, I cannot send presets to the e1 that way.
This is specific to the Mio10 and I believe that @martin is still working on this

1 Like

I was actually considering getting the MioXL to hopefully have a less buggy experience overall with midi and USB, but I’m not sure that I would.
Either way, as far as the script I’ll wait for the update on the E1 rather than rack my brain further on this issue:)

1 Like

I have not had a chance to test Mio10 and Electra connected with the USB. It works fine with MioXL and MioXM.

Yup, this is included on the 3.0 list. Electra can receive commands on any of the USB ports already (not just CTRL), this will be extended to all MIDI interfaces. When done, web editor will be able to reach Electra connected via a MIDI interface.

1 Like

Yeah I forgot but if you add 2 surfaces of electraones it works.

Top row is port3 bottom port 0
image

This way templates are send and displayed and controls work.
Probably just ok for a temporay sollution as the e.one gets sysex fatigue :slight_smile:

What? That works? Interesting :wink:

That does work! Amazing. Thank you :+1:

1 Like

This is quite amazing what you did there with your scripts.
Thank you for gifting us this!

2 Likes

I recently dived deep into @jhh’s work on this. I must admit I am truly amazed much work was done on that and how complex it is. Not mentioning that @jhh documented everything and even added a general tutorial on Ableton’s remote scripts.

It all helped me a lot to integrate it better to the upcoming firmware 3.0. By gaining this extra knowledge and having a well written remote script in place, we can really take things much further.

5 Likes

Thanks.

Please note I just pushed a major update out to GitHub to support the 3.0 version of the firmware. This version is NOT compatible with version 2.0 of the firmware.

1 Like

@jhh Regarding the 14-bit CCs. Electra recognizes them for CC 00 … 31. That is what MIDI standard says. It is quite easy to change this for CC 00 … 96. But will that work with Ableton?

@Martin just tried, but at least when doing MIDI learn it ‘learns’ the wrong CC-number: not eg. 0x40 but 0x60. So don’t bother - always best to stick to the standard, even if the standard is stupid :wink:

Or even better: I was always thought to be forgiving for input and strict for output, so allow incoming 14 bit CC’s in the second block (0x40-0x7F) but never send them out.

1 Like