Ableton Live MIDI Remote Script / Control Surface

I am not getting the dump to work and the sendmidi neither.

LIBDIR = r'C:/Users/SomeUser/eOne'

# This worked in the very old script
#LOCALDIR = r'E:/Ableton User Lib/User Library/Remote Scripts/ElectraTwo'


# Flag whether to use fast sysex uploading,
# using the (external) sendmidi package
# If True, correctly set the following two constants too  

# path to the sendmidi command, relative to local library directory (see LIBDIR)
SENDMIDI_CMD = r'./lib/sendmidi.exe'
# full path is C:/Users/SomeUser/eOne/lib/sendmidi.exe
# name of the Electra One port to which to send the SysEx command
E1_CTRL_PORT = 'MIDIOUT3 (Electra Controller)' 

2023-01-19T19:20:37.684352: info: RemoteScriptMessage: E1 (debug): - Fast uploading of presets not supported (command not found), reverting to slow method.

2023-01-19T19:21:01.598497: info: RemoteScriptMessage: E1 (debug): – Filter and order parameters
2023-01-19T19:21:01.598551: info: RemoteScriptMessage: E1 (debug): – Construct CC map
2023-01-19T19:21:01.599058: info: RemoteScriptMessage: E1 (debug): – Construct JSON
2023-01-19T19:21:01.601048: info: RemoteScriptMessage: E1 (debug): – dumping device: PluginDevice in C:\Users\SomeUser/dumps/PluginDevice.epr.

Note the home dir part and the rest… Doesn’t make a difference what you set in Looks the homedir is a variable

One little thing I noticed. I have a Live set with many audio tracks and each with the channel EQ plugin. When I remove a channel, E1 is updated correctly, but it gets automatically switched to the Channel Eq preset of the previous track. I would kind of expect to stay in the Mixer preset…

Yeah, I know. This is partially covered by the SWITCH_TO_EFFECT_IMMEDIATELY and APPOINT_ON_TRACK_CHANGE configuration constants, but not ideal yet. (And anyway not guaranteed to work if you have other controllers attached with their own device appointment routine)

1 Like

P.S. Will work on your suggestions for an alternative mixer design

Works fine with more Controller too

Can anyone confirm they use Sendmidi on windows with the script?

hehe, I should read manual for my own product. Great, I will take a look at the configuration options.

I have been using that without sendmidi so far. And it works fine for me. I will try to get sendmidi going today.


Hi :slightly_smiling_face:,
thank you @Flyweight for your help but I didn’t succeed with SendMIDI…
I’ll try again later… Never give up :rage:

I especially wanted to see if the data download was faster.
Currently for EQ8 it’s 3-4 seconds it’s already very good but… :innocent:

I noticed that the PRESET REQUEST button does not switch to the device preset. It only switches from preset to mixer for me. is it the same with you?

Otherwise, I briefly had the problem of “fader suddenly jumps back to zero” I reset E1 and everything was OK (I have a video and log if you want). Is it better to post log & bug reports here or on @jhh Github?

Bien cdlt.

Switching should work both ways indeed. Did you upload the latest version of the mixer preset (Mixer.eproj in the repository) to the correct slot (6th bank 1st slot)?

1 Like

I think the sendmidi with the remotescript on windows doesn’t work.
The LIB dir doesn’t work properly neither.
That might be the reason.

I wrote before I have tried all possible path declaration without success.

Whatever I try the script reverts to my homedir,

2023-01-19T19:21:01.601048: info: RemoteScriptMessage: E1 (debug): – dumping device: PluginDevice in C:\Users\SomeUser/dumps/PluginDevice.epr.

And for me also the controls jump back to 0 sometimes. And do not work smooth.

1 Like

I am sorry it doesn’t work for you. I will try to get my hands on a windows machine running Ableton to investigate and do tests in the future.

1 Like

Hi Jaap, thanks,

I do my best to debug but my python skills are baby level :slight_smile:

Anyhow really appreciate your effort.

Think Martin is trying a windows box as well



1 Like

I added an alternative mixer design that shows the transport controls on al mixer pages. See Mixer.alt.eproj. To use it, copy to


Unfortunately, the Plugin Device does not work since 3-4 updates. it worked perfectly until then. no longer for the last 3-4 Scripts. Plugin device preset is not even created in E1. The latest mixer preset is in the right place (bank6, p1), I didn’t change anything, only the color of the plugin device, and I turned off the “automatic switching”. What could be the reason?

Hi Jaap !

it’s hard not to be able to help you other than to show you the problems… thank you so much Jaap.

Yes, I checked, it is in bank 6 slot 1.
I tried quickly on the Mixer.alt.eproj and it’s the same.
PRESET REQUEST ne marche pas.
Tried to build a new Vinyl Distortion presets
and modify some existing presets. Now any preset is not uploaded to the E1 slot 2, is empty.

I’m going to reset E1 tonight.

ps: I just saw that @phonaak has a similar problem. business to follow…

Hi, I just uploaded 3.0.12 firmware to It is mostly result of working with @jhh’s remote script on both Mac and Windows. Along with work on the firmware I also proposed a small change to the remote script. I leave it up to @jhh if he incorporates it in his work.

I am currently (3.0.12 + altered remote script) getting a very smooth experience on MacOs and Windows 11. I use it without sendmidi as I did not see much difference in my setup. I can use sendmidi on MacOs without problems. On windows, I was able to configure it but the single-client issue prevents using sendmidi and Ableton in the same time. Ableton acquires the connection and sendmidi cannot transfer then. I am still looking at it though. I am not a Windows power user, so I need to get used to it a bit first…

I will be busy with windows for the rest of the day today, and I will be looking at the value jump issue.

1 Like

The last fw with the last Script works fine. :pray:unfortunately, the faster midi communication does not work (?)
I set everything in the file, as it was “shown” in a comment before, but the plugin device is just as “slow”. of course, it still works, and I don’t really use it, but I was curious.

1 Like

Just talked to @phonaak. He is on windows too. I just tested sendmidi on MacOS. That works just fine.

1 Like

It looks and works great. Thank you!

1 Like

I made that change (thanks for the suggestion) and pushed it to the repository just now.