E1 froze when loading a custom preset

Happy holiday season! Just got one E1 for myself as a present :slight_smile: but unfortunately I run into quite a few issues when using E1 with Ableton and the E1 remote script. Here is issue 1:

I am using a public preset, which contains 3 pages:

I am using it with the Ableton Remote script:

I have updated the Devices.py by running makedevices script. Ableton is able to load the custom preset, but after that the whole system froze. Moving any physical knobs or pressing any physical buttons on the left and the right side on E1 won’t cause the display to change.

Here are the .epr and .ccmap files I have in the preloaded folder:
Archive.zip (4.5 KB)

I just got the device and I have 3 weeks to decide whether to keep it. I would be thankful if you could let me know if this can be solved. Thank you!

Hi, I am the developer of the remote script. Saw your issue in GitHub; responding here.

It is hard to replicate/test this, because this preset appears to be for a non-standard device. Could you send me the device too?

I do notice a few things though:

  • the preset in the archive is different from the public preset you link too, and has some bugs actually: the group labels in the fifth column (like ‘LP GATE’ and ‘GLIDE’ should be in the sixth column it seems; now the overlap with a different group).
  • the CC-map in the archive appears to be incomplete (only mapping a few parameters); but this could be on purpose for testing perhaps.


Hi Jaap-Henk,

thanks for your reply!

  1. you can download the plugin here: Madrona Labs Aalto (you can use the trial version without paying)
  2. I didn’t change anything in the preset I sent you, so it’s interesting that the layout is somehow modified
  3. indeed the cc map is incomplete. I made another version by deleting all the sliders but the first two rows on the first page, and map all the available parameters in the CC-map file. The reduced version occasionally respond to moving knobs on E1, but eventually the E1 display will be frozen.

If you are interested, here is the reduced version:
Aalto-reducedVersion.zip (2.6 KB)

Let me know if you have any other questions!

Thanks. I tested some more and see the following:

  • the preset indeed looks fine on the E1 itself (it looks bad in the editor in beta.electra.one when I import it from the archive you sent in the previous message; @Martin any idea why that could be?)
  • for me the E1 does not freeze and turning knobs change the corresponding values on the E1 itself
  • however the preset maps the controls on MIDI channel 1 (see the devices section of the preset in the web editor), while the CC-map says they should be on MIDI channel 11, so the parameters in Aalto running in Ableton do not change at all.
  • there may be other things sending/receiving on MIDI channel 1 in your setup that mess things up?

@jhh Thanks so much for pointing it out! Indeed after changing the channel to 11 I am able to send MIDI data to Ableton live. E1 is still not updating the view when moving the knobs. Actually the reduced version of my preset in my previous message already updated all the MIDI channel to 11 in the preset, but I was confused with other issues on E1 (sporadic frozen screen, the view not updating). I have reported the the screen issue in another bug report, so this one can be closed now. Thanks again for the help!!