Freeze when changing pages (3.05)

Hello !

I’ve upgraded to firmware version 3.05 (from version 2.xx) yesterday because I’m having an issue with Ableton live which I might address in another post on the forum.

Since the upgrade the E1 freezes when I try to change pages in my preset. It doesn’t happen every time, but often enough to make the controller unusable (once every 10 switches maybe).

I’m using a homemade preset to control Ableton live. The preset is nearly full, the 12 pages are in use.

I tried two different versions of my E1 preset, both freeze in a similar way. I also changed the USB cable (you never know…).

I tried switching pages without Ableton running (I’m having an issue with midi remote feedback not working properly in ableton), same result.

I’m considering downgrading back to version 2.xx, any ideas ?

Hi @Jesse,

would you share the preset with me? It will help me to identify the problem. A link to the preset in PM is just fine.


PM sent :slightly_smiling_face:
And for future reference, the E1 also freezes on a preset from the library.

1 Like

@joris.roling reported similar issue. It is happening to him with the Bacara preset. I have not been able to replicate that yet though. I am trying to find the cause.

i just installed 3.0.6. So far I haven’t had this problem, but with the new fw, unfortunately, the E1 freezes every second page switch.

I am on it. I am able to replicate the issue and I am working on fixing it. Version 3.0, which is not affected, is available at the downloads page. I am hoping to have this resolved by tomorrow.

1 Like

i am on 3.0.5
Initially I was not able to access any presets.
They are visible on the gui.
After another reset I was able to see the “presets page”. After loading the first preset I switched a page and it hangs.

When pressing the “pages” button and the bottom left button the screen dims.
So the unit is in standby.
When subsequently pressing menu I see the preset shortly. it flashes once.
I am not able to enable the device again
Pressing “pages” + button 3 and it dies completely. .

Strange after i did this the preset pages switch finally.
So I fixed the issue before @martin hihihi

There is an updated version of firmware on It is the latest version of the firmware but with the new page switching gesture reverted. @Jesse confirmed it works for him. It would be great if somebody else could give it a try and confirm it is fixed. I would love to do that by myself but none of my Electras have that issue. Thanks!

I’ll be home in an hour, I’ll try it and then I’ll write. What exactly does “page switch gesture revert” mean? Is the “one-handed page switch” left?

yes, I have to temporarily disable that until I fully understand what is happening there. I will work with you on getting that going again.

1 Like

Now (3.0.9) works without error

I have just released the 3.0.10 to the production. Amongst other changes, it makes the fix of Page switching issue available to all users.

1 Like

I am on 3.0.10 and all my issues are gone. The unit seem to work great. even with the Ableton control.
Will test and try my templates, they used to crash on sysex parsing.