New user: E1 does not connect to Ableton Live

Just got my E1 today and trying to connect it to Ableton Live, no luck so far.

I have connection from
I followed the instructions on GitHub - xot/ElectraOne: Ableton Live MIDI Remote Script for the Electra One
I’m using Ableton 11.3.22 & Windows 11, all up to date
Firmware E1 is up to date
I use other midi controllers: Push 2 and Arturia Keylab MKII, they are working correctly

No midi signal is coming through from the E1, I check this using M4L MidiMonitor
In options/preferences/Midi there are three entries for Electra Controller In and three entries for Electra Controller Out. The second and third entry have suffix (Port 2) and (Port 3).
In I think I can choose which of these ports will be used. None of them is working

Any ideas?

I think I just discovered that you either have the connected to E1 or Ableton Live connected to E1. It’s not working for both together at the same time. Still no midi coming through…

Hi, can you share a screenshot of your MIDI preferences? Something like this:

and any of the MIDI tracks:


I checked the track checkboxes like you did for E1 and now there is midi received in the track.

No response yet from E1 in Ableton, so nothing happens when turning knobs…

Well, something is working now. When I turn a knob on E1 the modwheel is changed using the preset ‘Ableton Mixer V6’. So midi is sent from E1 to Ableton. Unfortunately it is the wrong control: If I turn the pan knob of track X+1, then the modwheel is changed…

I simplified some things: I use Collision instrument from Ableton on one track. Midi is coming in, but the instrument is not responding. I use preset 1 in Bank 1 for this

Hi. If you want to use the E1 to control the mixer and devices in Live, make sure you follow the installation instructions: GitHub - xot/ElectraOne: Ableton Live MIDI Remote Script for the Electra One
In particular:

  • in Live MIDI preferences, only check the ‘remote’ checkbox for the input Electra Control (and not also the ‘track’ checkbox as your screenshot shows).
  • Add `Electra One’ as a control surface with Electra Control as input and output.
1 Like

Hi jhh,

Thanks for your reply. I figured out what went wrong: It seems I have to use a different location for the Midi remote scripts. I got a hint from this website:
Writing Custom Control Surfaces for Ableton · discrete blogarithm (
These scripts are stored in /Applications/Ableton Live $ Resources/MIDI Remote Scripts/ on Mac (where $VERSION is 10 Suite for instance if you have Live 10 Suite installed) and \ProgramData\Ableton\Live x.x\Resources\MIDI Remote Scripts\ on Windows.

It now seems to function as intended.

Going to have fun now. Thanks for all your effort!

1 Like

Glad it is working for you, but you shouldn’t have to install the scripts within the application folder itself. The paths mentioned in GitHub - xot/ElectraOne: Ableton Live MIDI Remote Script for the Electra One
should work (although there was an error in the Windows path, that I thought I fixed one or two days ago).

1 Like

Hi Jaap-Henk,

I still have a question. Creating presets on the fly is working fine, I like that a lot.

But I also want to try predefined presets (or create my own presets). In the manual it says:

The remote script looks for a preset for the appointed device using the device name, first as a preloaded device on the E1 itself, and then as a predefined device in . (For older, mkI, E1 the first step is skipped.) It uses the first one it finds. You can edit or add your own favourite preset layouts as described in this separate document.

I do not understand this. A preloaded device on the E1 itself: what does that mean? Can I preload a device? How?
I put a preset called U-he Diva in mypresets in I changed the name of the preset in Diva to match the name of the device in Ableton. I sent this preset to E1. But still it will not show, presets on the fly are still created,

All of that is in principle explained in this document ElectraOne/ at main · xot/ElectraOne · GitHub
But I agree the process (and the description) is quite technical and complex. I’ll have to think of a way to make it more easy (and to describe it in an easy to understand manner).

I tried following the instructions in ElectraOne/ at main · xot/ElectraOne · GitHub

What I try to do is to add the U-he Diva preset from to the ElectraOne\preloaded folder. (I renamed U-he Diva to Diva)

I have copied the epr file in there but I can not find a cmap file anywhere. How do I get a cmap file?

Typically what you should do is this

  1. Enable dumping of presets (set DUMP = True in
  2. Start Ableton, make sure the remote script is active
  3. Load the device you want to create a preset for and select it; a blue hand should appear in it (and the preset that is constructed on the fly should appear on the E1).
  4. This should create <devicename>.epr and <devicename>.ccmap in the dumps directory in the library folder (LIBDIR).
  5. Copy <devicename>.ccmap to the preloaded folder
  6. To edit the preset, import <devicename>.epr in Once you are happy with the result, export the preset <devicename>.epr and save it also in he preloaded folder.
  7. Run ```makedevices````
  8. Restart Ableton.
  9. If you now load the device again and select it, the preset you created should appear on the E1.

Hi Jaap-Henk,

I think I’m almost there…

Step 7, 1. Run ```makedevices```` is not working as intended I think. After step 8 restarting Ableton the changed preset is not show, just the on the fly preset is shown.

First of all I renamed makedevices to to be able to run it with Python.

In Windows Explorer I double click on the script and a popup command window is shown. When I put a new device in the preloaded folder I can see the command window processing lines (scanning devices in the preloaded folder I presume). When I want to run it again the popup command window is flashing very quick (is it skipping the scanning somewhere?)

Should makedevices change the contect of This file is not changed and my preset is not in this file after running

Hi Jaap-Henk,

Got it working somehow. I installed Studio Code Visual to run At first I got an error when debugging:

Blockquote[Errno 2] No such file or directory: ‘preloaded\MidiPitcher.12.ccmap’
File “C:\Users\fboek\Documents\Ableton\User Library\Remote Scripts\ElectraOne\”, line 123, in process_preset
with open(ccmap_path,‘r’) as inf:
File “C:\Users\fboek\Documents\Ableton\User Library\Remote Scripts\ElectraOne\”, line 194, in
FileNotFoundError: [Errno 2] No such file or directory: ‘preloaded\MidiPitcher.12.ccmap’

I think the spaces in the path name were not recognized. Somewhere along the debugging trail the error vanished, I don’t know what triggered that. I’m not familiar with Python.

This path still is not working for me:
C:\Users\fboek\Documents\Ableton\User Library\Remote Scripts\ElectraOne
So I still use this path:
C:\ProgramData\Ableton\Live 11 Suite\Resources\MIDI Remote Scripts\ElectraOne

It would be nice if this could be working as intended. Now in the first location is working but I have to copy to the second location to make it work, it’s a bit confusing, not a real big problem though.

So now I can make my own presets, that’s nice!

Oops… my bad. I forgot to add MidiPitcher.12.ccmap to the repository. It is there now!

I solved my issue with the path of the Remote Scripts: I had relocated this folder to an external drive. I discovered this by right mouse click on the User Library in Ableton and select “Show in explorer”

Good. Because that’s the path Ableton itself also recommends for remote scripts:

I’m meanwhile thinking about how to remove the requirement to run makedevices as this required that Python is installed and this may not be the case for most people. Also running it from Windows Explorer is non trivial.

Done :wink: Check out the latest version of the repository.

1 Like

I just tested this, this works. Very nice.

One thing I noticed: in the dumps folder spaces in the names are removed. Is this as intended? It seems not to mather when matching the name with the instrument rack&device name in Ableton.

1 Like