E1mkII problems


I just did a few tests with my new E1mkII. For this I used the preset DX7II and tried to create a few snapshots. Unfortunately, many strange things happen (still):

  • complete freeze of the UI
  • Switching the screens suddenly doesn’t work anymore (but the encoders react)
  • Nothing works anymore, but touching an encoder is recognized
  • Snapshots are saved incorrectly (e.g. OPs 1-3 were switched off after loading, although they were activated before)
  • buttons react sometimes delayed or only at the second pressure

I think that these are still startup problems of the new E1mkII. Unfortunately, it is difficult to note the exact sequence of the problems - they are just too different and appear so often. I can’t work with E1mkII yet.

Do others also have these strange problems? Then at least it’s not a hardware problem of my E1mkII…

Curiously waiting for a bugfix release, Holger

1 Like

Hi @C0d3man, I will try to reproduce what you are doing. The snapshots are stored in an a sqlite database. As you got your unit at the time of Superbooth, I am not sure the database is set up on your internal storage correctly. I am available on chat (almost any time this weekend) to review that with you.

Hey, yes i think i have some of the same problems.
But i have it when i press more than 2 (short)times on one of the left buttons, i think… but i’m so new to all of it, maybe its something els. I got a video if it i think.

ok, I am looking at it on my E1. any hints on how to replicate it are welcomed!

Thanks, Martin! Badly I have no time until tomorrow around 12:00. So I will come to chat back afternoon.

Can i send a video? For me its in main sceen(with ableton mixer file)
Pressing more than 2 times on one of the left buttons.
All freezes…

yup, please share it. Thanks!

Sorry, the max in 8mb. So i will email it?..

@Tweakfreak would you be willing to share with wetransfer.com or some similar service? Just so that I can see that…

Sure! This one is the right video:

1 Like

Great, That bug is a dead one.
No freeze anymore!
Thanks Martin,
What a machine💟


first off, thanks to @Tweakfreak to work with me on it. It really helped!

The problem was in pressing the left-top button while holding the knob. That is a combo gesture to open the control detail window. Unfortunately, the firmware tried to open it for pads too. And they do not have control detail window.

It is fixed in upcoming firmware v3.2.1. I will wait for one day or so. just in case any other issue would be spotted. Then I will release the update to all users.


Hahaha ! The bug works great ! just tried it on my mkI ! :grin: :see_no_evil:


Yes, I think it might be one of those mysterious issues, because it may happen incidentally. Kudos to @Tweakfreak because he really puts his new E1 under quite some stress :slight_smile:


@martin I may have another one: lua midi.sendControlChange method doesn’t seem to work for me.

a test preset: Electra One App
(when the fader message type is switched from virtual to cc, midi console does show the outgoing messages and ui “midi 1 out” lights up)

it works perfectly for me too. :slight_smile:

I going to look at that now. I will let you know when I need assistance or when it is fixed.

Great, pls ping me when you are available.

Hi @martin,

I deleted all my presets on my E1mkII and added them again. After that the problems seems to be gone. I will go on with programming my setup. Thanks for the hint!

Regards, Holger

Fixed and tested with @1AM. The final fix will be included in the upcoming firmware release.