E1mkII problems

My E1 Mk2 appears to freeze at random and when using various presets. it doesn’t go more than five minutes without freezing. I have tried various power supplies all above 2A.

Hi, there was a software defect discovered. It locks E1 when touch and hardware buttons are used. I have already prepared a firmware update. I will make that update available to all users tomorrow.

I will reach you on the chat, to test if that update resolves your problem too.


As the procedure has been field tested by a few users, I am going to share it here:

Firmware update Electra One mkII

I am going to integrate it to app.electra.one so that users are informed about updates directly in the editor.

All mkII users should update. There is handful of changes based on feedback from the users after the first week.

PS: I am available whole day to assist if it is needed.


No further problems after installing 3.2.7, many thanks martin.


@martin I may have a couple of fresh ones:

  • Version 3.4: Screen port labels are not being highlighted upon receiving/sending data (checked a couple of older versions - last firmware it works with for me is 3.3.1)
  • Version 3.4: MIDI Routing is not being saved using the online config editor. To reproduce: Try changing some routing options, click “Apply”, close the browser, re-open and see default options restored. Seems to save routing options fine on 3.3.1, however…
  • Any 3.x FW version: routing “MIDI IO → MIDI PORT 1” or “MIDI IO → MIDI PORT 2” never works for me, even with 3.3.1 which seems to be able to both save routing options and highlight port labels when there’s any activity
  • When feeding E1 midi data from an external sequencer via the “USB DEVICE” port, it goes into an infinite reboot loop within a few seconds

Would be great in someone reading this could also confirm or negate any of the above

P.S. A feature request: I would really like be able to change preset generic midi channel and midi routing options from E1 itself, without having to connect it with the computer


Update: It seems that the second bullet point is actually the nuxt web app bug, not E1. The app won’t read the current midi routing config unless you disconnect and reconnect E1 while the “controller > configuration” tab is active

yup, that is correct. It will be fixed in the next release.

verified. reloading the page with the configutration can be used to read the configuration. I will look at it.

I am unable to replicate this one. I get MIDI data forwarded when the option is on.

it means sequencer running on the computer? Do I get it right?

1 Like

Thanks for confirming this @martin

I’ll wait for the new FW and see if I still have any issues.

With some simple configurations I’ve been able to confirm that all the ports work both ways,
so at least I know it’s not the hardware. Perhaps the presets I use, or indeed the routing…
I’ll test again when you release the new version, then document the steps to reproduce my use case in a bit more detail, if necessary.

Just received my unit and was working fine 2 days ago receiving midi in, now USB Device, USB Host and Midi 1 In just blink momentarily while receiving a constant midi in signal. Not sure what is going on, midi out works fine.

Edit: Video of what is occurring, not sure if I just bumped a setting somewhere? First is me controlling the parameter via electra, then controlling the same parameter from the synth panel.

Edit2: Tried with a different laptop and powerbank, still the same issue. Switched over to a different device and I’m only receiving note values to midi in. Any ideas? At this point I am unsure of what else to diagnose. I also re-flashed the unit when I initially started having these issues even with the unit only being received this past Thursday.

Hi @Cubeinthebox,

Is the synth connected directly to E1 or is there any device in between?

Pls try to observe the MIDI traffic that comes in. This is the steps to do:

  1. Open the editor
  2. Click on the “Lua and Tools” in the top toolbar
  3. Click on the Debugger icon
  4. Set the log level to TRACE and click the “SET LOG LEVEL”.

like this:

Now, when you twist the knob on the synth, what do you see in Debugger window? You should see info about incoming data there.

Pls let me know. Thx!

Hey @martin

Have the devices connected straight I/O via DIN cables. Here’s the log info with me twisting the knobs on the virus. Constant data is being sent but only blips of midi is being received by the electra:

12:50:54.367 SysexApi::process: application system call
12:51:04.290 processElectraSysex::logger enabled: logLevel=3
12:51:06.252 ElectraMidi: processMidi: Control change midi message: parameter=25, value=55
12:51:13.980 ElectraMidi: processMidi: Control change midi message: parameter=25, value=53
12:51:18.806 ElectraMidi: processMidi: Control change midi message: parameter=25, value=41
12:51:24.837 ElectraMidi: processMidi: Control change midi message: parameter=17, value=60
12:51:29.685 ElectraMidi: processMidi: Control change midi message: parameter=17, value=78
12:51:34.411 ElectraMidi: processMidi: Control change midi message: parameter=17, value=77
12:51:39.065 ElectraMidi: processMidi: Control change midi message: parameter=17, value=47

I’m twisting knobs in this scenario but you can see the lag in timestamps between the recorded values.

I was able to replicate it. I am working on the fix. I might reach you on PM when I need to test it on your side.


Glad I’m not crazy! I’m around today if needed, thanks for checking in.

1 Like

this was actually the same issue with the running status as in Octatrack cc#61. Fix is included in the upcoming release.


With firmware 3.4, I’m still experience knob pauses/jumps when trying to turn 3+ knobs at once on the Default Preset. I’m able to repeatedly reproduce this by turning CCs 1, 2, and 7 simultaneously.

I can also reproduce the issue where the knobs become unresponsive and then suddenly jump half the range, or just jump in the opposite direction for 1-2 values.

I am running on beta firmware 3.4.6.