Electra is going crazy

It’s probably due to the touch screen getting many false informations.

Is there a way to disable the touches completely ? I barely use them, the knobs are too good.

Here is a link for a video: https://photos.app.goo.gl/ahLTmV8AAwdmm5gv6

Thanks !

Hi Bruno,

this is happening due to E1 not getting enough power from the computer (or another source of USB power). When there is not enough power, the touch sensing chips (LCD, knobs) tend to invent touch events.

The usual reasons for running into these problems are long or lower quality cables USB cables or the computer / hub not being to keep stable 5V voltage at higher currents (500mA). If the latter is the case, you can use a powered HUB or a USB Y cable to provide stable power.

Let me know if this helps.

PS: your message was marked as a spam by the forum software - I whitelisted you to prevent that in the future.


1 Like

Hi Martin,

Thank you very much !

Indeed I’ve had powering issue with the E1.

I hadn’t thought about a USB Y Cable, but I’m using this kind of USB Hub: https://www.amazon.com/RSHTECH-Transfer-Charging-Individual-A37-Black/dp/B07RQYFYN6?th=1 (mine is with 10 ports) I thought that would be enough.

Do you have any recommendation for a hub that “always deliver” ?

Thank you !

I use the Electron Overhub, with its own power supply.
3 reasons to choose it:

  • with its separate power supply it can almost max out every single output port
  • it’s an MTT hub, which allows it to scale up old USB 1.0 devices to a higher rate, while normal hubs would scale down the transmission to the slowest device. This is important once you use the hub for MIDI notes transmission and certainly for MIDI clock.
  • the main connection to the PC can be USB 2 or USB 3.

I now have two of them in service, one connected directly to the PC, and one to expand the USB ports on an Iconnectivity MIO xl. Never looked back since.

Mind you , some people with Macbooks have had issues using the Overhub and older models were notorious for bad soldering…

I addition to that, check your power supply of your hub. If indeed it delivers 3 Amp at 5V and the total power consumption of all ports in use remain below that 3 Amp , you should be fine. If theoretically these boundaries are respected and you still experience Electra issues, chances are that one of the connected devices is taking much more Amps than allowed by the USB transmission protocol ( I suspect your ‘fast charging’ ports of that behavior). Pull them out one by one to find the culprit, and try again by connecting to a normal port instead of a fast charging port.
If almost nothing is connected and the Electra still goes crazy, then your power supply is probably dead.

Thank you @NewIgnis ! You’re right, I will do a full review of what power is delivered to the hub, and what is connected to it, which I have never done.

Thanks again

I had the same problem, Martin and I couldn’t figure out what was causing it for a very long time.
I used a good USB hub, I tried several, with several power supplies It was interesting that this appeared only “in certain cases”.
The solution,…it is also interesting …,that a decor “Plasma ball” was plugged into the same electrical distributor to which the USB hub’s power supply was connected too. When I turned on the Plasma ball, this problem appeared.
Try without connecting anything else to the distributor, only the power supply of the usb hub, then turn on the E1. the Plasma ball was 12V reverse polarity. talanez also counts. somehow she “contaminated” ubs so much.