Firmware 3.0 and Electra App update

I’ve only been using the beta app for the past few months, since I installed beta fw3. there was no problem with it. then the normal app would have worked fine with beta fw3?


by using beta firmware with you might risk running into problems. It always depends on the nature of changes that are being tested.


After updating to 3.0 I seem to be unable to change presets on the E1. Pressing the lowest right button brings up the page selection menu with a different look than firmware v2 and I can’t seem to access other presets. Is there something different I should be doing for v3.0 to access presets?

1 Like

Try holding down the right lower button and press the right middle button

1 Like

Thank you! I thought I tried that already.


started playing around with MIDI functions and tried to use transport.onClock(midiInput)
but I see an error in the logs – lua: function onClock does not exist

what is the transport callback for MIDI clocks?

EDIT - actually none of the transport.xxxx() callbacks seem to be recognized. Only transport.enable()

Its by heart so not entirely sure, but try midi.onClock

1 Like

yep - that was it; thanks much.

1 Like

Follow-up question (probably for @martin )

When I send MIDI start, stop, and clocks to the Electra One across the MIDI DIN Input port, I see the “MIDI IN” banner flash at the port when the MIDI Start and Stop messages arrive, but I see the “USB Device” banner flashing with each clock pulse and not the MIDI IN as expected.

I can see muting the flashing for clock pulses to save processing time, but the USB Device flashing puzzles me – is incoming MIDI clocks being forwarded to the USB device port behind the scenes?

In my controller configuration screen I have no forwarding of any messages checked. It happens even when I am powering the E1 from a wall wart adapter and not the computer.

EDIT - I’m guessing it’s debug messages being sent to the USB device port.

I need to dig up the debug on/off sysex strings so i can turn off debugging when i get a Clock Start and back on when I get a Clock Stop. That should help get more consistency.

EDIT 2 - ok, I sent the logger OFF message (and see it in the debug log) but the USB Device port banner is still flashing as if clocks are being sent out that port.

Much confusion, but likely won’t be back on line much for the next couple days; certainly no dedicated time to do more coding/debugging/playing.

Nice! Is there a change log somewhere?

I am sorry. Not really. The 3.0 is basically a complete rework of what was done so far, almost everything has been changed or at least touched. The complete information about the features of 3.0 release can be found at

1 Like

Some user and I have been helping Martin with testing the beta. If you can’t find something yourself which you had on the FW2, do post it here, and we’ll help you get to it.