Firmware v3.5

A new firmware version is now available for download. For the complete release log, please visit Electra One firmware v3.5.

Important note for Ableton users:

Firmware v3.5 introduces support for pre-loaded presets. This feature enhances Ableton integration by storing many standard device presets directly in the controller. This eliminates the need to use the sendmidi tool on macOS and significantly speeds up device preset loading. To make use of pre-loaded presets, please follow the instructions provided at: xot/ElectraOne preloaded-presets.

While the use of pre-loaded presets is recommended, it is optional. Big thank you goes to @jhh for his work on the Remote Script!


Thanks Martin for your hard work. I have updated my Electra. This will be fun :grinning:

1 Like

Martin - quick question – I thought that if I sent a
msg = {0xF0 0x00 0x21 0x45 0x02 0x7F 0xF7} (formatted properly of course) to PORT_CTRL
from a LUA function, I would be able to get the current OS version and other info.

However, it appears that does not work. I can send that sysex from the MIDI console and I do see the response; just can’t get it to work from inside LUA.

Is there another way to get the OS version on preset load?
The idea of course is that if the preset depends on some advanced functions (or mk II hardware), it would be good to know up front and alert the user.

1 Like

I am finishing v3.5 for mk1. It will go to beta either tonight or tomorrow. I am happy to say that all new functionality (except parallel presets and data pipes). Given that, the major constraint will be the memory.

I have recently added a new Lua module controller. It currently provides info about the controller uptime only. I will extend it with calls to fetch firmware, hardware version and the E1 mark. It will be available in upcoming minor release.


Wow - that’s some good work. I was wondering how much of the new functionality could fit into the mk1.
The updates may give me (and others) enough flexibility so that we can re-use controls and save some memory that way.



Looking forward to test the update :slight_smile: Thanks for working on both devices!

1 Like

v3.5-rc1 for mk1 is on

I am currently looking at some issues with formatters and moving controls around the pages.

as promised, I will try to keep mk1 in sync with mk2 whenever possible.


v3.5-rc2 is available:

formatters resolved
Control slot changes work. It is actually an issue of the Lua timers.

1 Like

Hi There,

You mean that 3.5 will take much more memory than previous firmware on mk1? Could 3.5 affects some presets loading?

No, not really. I am doing my best to fit all mk1 presets in (although @joris.roling Access Virus has always been quite a challenge ;). What I wanted to say is that all the new features are inviting to do fancy stuff, but mk1 can reach its memory limits soon.

It is also important to say that I keep snapshots of all presets to be able to provide mk1 compatible versions of presets in case of further preset development on mk2.

1 Like

Hej @martin, just upgraded to the beta - starts up the Electra very fast :smiley:

I tried to save some NRPN snapshots of my Ambika preset and it has frozen the Electra.
After reboot, I tried to load them back to the Ambika but still no luck in changing one parameter.

I tried different Rate [MS] settings from 2-1000 in the Editor for saving/loading. No reaction.
My MIDI monitor shows all sends from the Electra in nearly the same milliseconds with every setting.

I can test further, if you have a hint, how to tackle the NRPN snapshot loading and freezing while saving.

Best from Berlin,

Hi Björn,

I tested that with you Ambika Yam preset, and it seems to work fine (in my setup). Can you test that with no MIDI devices connected to the controller? And can you try to save and load snapshot of another preset - something simple like CC demo. Thanks!


1 Like

Hej @martin,

I did some more testing :slight_smile:
About my setup: I have no MIDI jack connections to the Electra – it’s all USB routing from and to the Electra.

I cut down my Ambika preset to two parameters, and it worked with altering them with snapshots

I tried one whole parameter page next, but had no luck with the amount of parameters:

My MIDI monitor gives me these sends from the Electra:

There are at least 8 parameters send on the same ms time… even 30 parameters at the same ms further in the log.
Can I alter that somehow?

And my Electra is behaving weird often with snapshots:

Sometimes all saved snapshots are immediately gone after leaving the snapshot view. After reboot, one old one is there again, or the Electra freezes on the snapshot screen. Reboot again and it works.

The problem with lost snapshots also occurred, after I loaded the CC demo onto the Electra. Maybe it’s a problem with direct snapshot for presets newly uploaded to the Electra? I can reproduce it.

Sometimes the snapshots screen hangs while saving.

Sometimes the two parameter preset hangs directly after reboot.

Greetings from Berlin :wave:t2:

I tried updating to the new firmware, and i borked my machine… i’ve been trying to figure out how to do a factory reset on the mk2 and i can’t find documentation anywhere. (theres one link but it dead.)
Hard reset

I think for mklI this here works: Electra black screen :( resolves with a hard reset - #6 by martin

Hi Björn,

it looks more like your SD card (inside E1) has troubles. Pls ping me on the forum chat, when you are available. We can do some tests together.




Hi Martin,
is there a possibility that Electra can’t see my devices after update?
circut tracks added after update is recognized by usb host.
micromonsta 2 (3 different cables checked) or roland sh4d power up but are not recognized.
any ideas how can i make it work?
thank you

cannot get the 3.5 firmware update, “you have already the newest firmware 3.2”?!

It is not final for MkI: you can get the Beta from here: Electra One App

Just a quick update. 3.5 is now out for mk1 too. Users, who updated to beta versions, might want to use the recessed “update button” on the back panel to switch to official release. ie. click the update button, then “Force firmware update” button in the web application, and then proceed as usual.