Knobs No Longer Work After Firmware Update

Greetings,

I recovered from a failed firmware update and my device powers and at first glance looks functional. As I got back through my presets I have noticed the knobs no longer work.

I have tried going back to the last firmware, flashing that… still the knobs don’t work. Then back to the current firmware and the knobs still don’t work. Does anyone have any suggestions? I don’t think I can get along just using the touch screen.

Thanks,

-Matt

Hi Matt,

I think you mentioned that you hard-reset your unit. The hard-reset may affect the calibration of touch sensitivity of the knobs. If the knob touch get out of calibration, the knobs will not work - Electra reads only knobs that are touched by fingers.

To test this out, do following:

  1. disconnect electra from the USB
  2. press and hold the left-bottom rubber button
  3. while holding the button pressed connect the USB cable and keep the button pressed till the start animation is completed. (it means around 3 - 4 seconds)

Now, try to twist the knobs. It should work but you will not see the indication of knobs with touch. Ping me if this works for you, I will send you a special firmware that will recalibrate your unit.

I will be leaving the workshop in a few moments, so I might respond a little bit later.

Martin

1 Like

Thank you sir! You are a wizard of your craft :slight_smile: I had looked up the other instructions on this forum to do a factory reset with holding the left middle button and that didn’t work. I am glad that this worked.

Thanks so much,

-Matt