Pots not responding on startup

Basically every time i power up my E1, the pots don’t respond (to touch or turn). I thought it was sorted by just disconnecting power (or not using USB power from the computer) - and sometimes it works, but it’s not stable.
Any experience with this or tips on how to solve it?


Hi Jasper, if the pots do not respond to touch or turning it looks like that the calibration of the touch sensing chip does not go ok or does not complete. I will reach out tomorrow to check that with you.


Thanks @martin !

looking forward to hearing what i can do

I was having having the same problem. E1 mkII, fw 3.4.0.

All was working OK the first few times I used the device. Only things I’ve done differently recently are started working on a preset and then put E1 to sleep (Menu + option 3). On waking up, pots not responding to touch or turn. I disconnected and reconnected to USB a few times but no joy.

Pressing the physical ‘reset’ button while powered on immediately fixed it for me and everything has been fine since.

Thank for the input! I did also try that the first time this happened to my E1, but I don’t remember it fixing the problem. I will try it again. I wonder though what the reset button does differently from just disconnecting the power…?

1 Like

Yep, maybe I just got lucky as the docs say:

The effect of pressing the preset button is the same as disconnecting and reconnecting the USB cable.

1 Like

Hi, I am looking at it now. I have one unit here that has the same problem. I will share more info as soon as I know anything.

Reset pulls the reset signal on the main CPU down. I do not think that it can really resolve the problem. It is more like that the calibration went ok after you reset the controller.

1 Like

Hard power cycles will usually draw a bunch of current at once when the switch is flipped and could have problems if the USB port powering it can’t handle the max during a cold start. That then could interfere with calibration.

Soft reset won’t result in the same peak current draw so the calibration could run when it’s already in steady state and the capacitors on the power supply still have charge.

1 Like

It is actually a slightly different behaviour due to different firmware version in the touch sensing IC. I hope I got things right so that it will work with any version.

@cryingboyscafe @keybits can you please try to run the following firmware -
firmware-touch-fix.srec.zip (1.5 MB)?

Please note, it is meant to test whether or not the touch will become stable on your controllers. Do not use that firmware for anything serious yet. If you confirm that the issue has been resolved, I will clean it up, test, and prepare a release. Thanks!


Thanks for the quick response Martin. The issue had recurred for me so I was able to test with the new firmware.

On first boot with new firmware pots are working again. I’ll let you know if anything changes!

Please give it a few hard reboots as well as let it running for some time. Fortunately, Zdenek passed me one unit that had the same/similar issue. It seems to work just fine so far.

Thanks Martin! Will do that tomorrow morning and let you know (after checking how to do a fw update :eyeglasses:


My unit arrived today. I loaded a few presets from the Library (Thanks, folks!) While the touch screen worked, I was getting absolutely no response from the knobs. Came here to research, and sure enough, the reset knob did the trick. Good to know this resource is here!!

please note that final fix of the problem will be included in the firmware update. The resetting the unit and running the firmware 3.4 does not guarantee that the problem will not come back.

I am sorry for the issue, it seems to be related to boards from the latest production batch where the touch sensing chip with newer internal firmware is used.

Also note that Zdenek tests all controllers prior to shipping. He would never ship a controller with a problem. It seems that his workflow: connect USB, flash bootloader, flash firmware, reset, test functionality - perfectly hides the issue. He will adjust the procedure. But the main point is that it is a software/timing issue and it can be fully resolved with the controller firmware update.

Hi Martin, no worries and all good.
I just updated my E1 and where I already was getting used to having to power it up multiple times before the pots would work, it now also works instantly (like @keybits mentions). If “hard reboot” means disconnecting the power and plugging back in, I did that a few times and it still works. I’ll keep it running today and test it once in a while. Let you know. Best, Jasper

1 Like

Have restarted several times by pullling the USB cable and all working fine with the firmware posted above. Also left E1 on overnight and everything fine the next day.

touch sensing chip with newer internal firmware

Thanks for sharing this info Martin. To confirm, there is no hardware issue with these units? Instead it was a firmware / software compatibility issue?

Yes, that is correct. I am finishing an update and I will add a notification on the electra.one website. I am quite sure more users will be affected.


Also had the E1 on for a few hours now (and booting it now and then) and still stable.