Lexicon PCM 80, PCM 81

Give it a try and let me know. Requires a mk II Electra One w. 3.5 firmware.

PCM 80/81

More info in the preset description

1 Like

After hitting Sync, my mk II E1 w fw 3.5 shows PCM 81 1.00 and 42 algs - DualFX 1.0.
What are your plans for this preset?

Plans are to finish it of course. I just got so burned out coding that thing day after day using up all my free time that I needed a break.

Now that I know the dumps are being properly processed, and the fact that Martin have made some excellent tweaks/additions to the OS since I last visited it, my plan is to finish up the Pitch page (which needs work for sure), then test out the various combinations of PCM 80/81/OSes/cards to make sure it handles all them.

After that, I want to work on the patching page so that the destinations show up using the correct ranges and values and formatting like you see on the PCM display (i.e. instead of showing 0 to 560 it shows correct values for Low Rt or whatever).

Then there’s the whole patch saving section and any other odds and ends I forgot. However, I would appreciate it if people played with what is there and gave me feedback (email/PM is fine) about how useful it is, any wrong values/errors, etc.

As an aside - to “take a break” I started a preset for the tc D-Two delay and should have a working version of that up some time this week for folks to play with and comment.

Bottom line is that even though a basic editor seems sufficient, I really want to close the loop and make the preset as complete as possible so that users don’t have to jump back and forth between the Electra One and the hardware. HOWEVER, that sometimes would mean nothing gets published until much later. I’d rather release a working version that is (hopefully) helpful to some, get feedback, and work on it as I have time over the course of days/weeks/months.

1 Like

Since I cannot edit the original post, here is an updated version.
Needs Mk II hardware, recommend using 3.6.0 OS (might be OK with 3.5.4).

Still struggling with the Pitch algorithms, but most things (maybe even the Submixer in the Dual FX) is working.

Testing, patience appreciated.

Currently, the only algorithm that is definitely broken is alg 56 (Pitch Correct). The others should be working, but the master/voice relationships are a known issue.

latest beta PCM 80 thing


Recently added screen touch to toggle between ms/echo:beat and to jump character sets when naming.
I believe it is feature-complete. There will be some tweaks and cleanup of course, but at this point, I think all algorithms and cards are supported and you can edit and save patches back to the PCM.

Anyone using/testing/playing, please provide detailed feedback and I will attempt to address them promptly. This is a complex editor and there is 100% probability I did not test every single bit of it.

Hopefully it opens up the amazing world of the PCM 80/81 to more people and more interesting effects.


Hey guys, just got a MkII brand new. Firmware is current (3.6.1), I’m not experiencing what Resyn did when hitting Sync. Also, adjusting any parameter with a knob turn/touch results in the PCM81 displaying, “SysEx data error…” I checked all cables, routing, PCM MIDI settings, etc., nothing seems set incorrectly.

Any ideas would be much appreciated -

A few things to check.
First, to simplify things, is the Electra One directly connected to the PCM 81? (i.e. no MIDI patchbays, no mergers/splitters in between?)
When you first press the Sync button, the Electra One goes out via MIDI to ask the PCM what model is it, are there any cards, which OS, and so on.
After the Sync is successful, you should see in the upper left the OS, number of algorithms, and any card information.
Also you should see the Patch Select and Save buttons.

If those things do not appear then Sync did not work. This is usually because you have the Electra connected to a computer via USB and you have something running on the computer like a DAW or Sysex LIbrarian or MIDI-Ox or MIDI Monitor that is echoing MIDI data back to the the Electra One.

Let me know if this helps.

First - thank you very much for the quick response and willingness to assist!

I have only a pair of DIN MIDI cables connecting Electra to PCM81. No routers, splitters, hubs and no other MIDI apps running at all. Upon pressing Sync, the PCM display indicated a bulk MIDI dump, but no OS/algo/card info appeared in the upper left at all. I have rebooted the PCM and also did a MIDI reset on the PCM. Any other ideas?

Sanity check - the cable in the back of the PCM is connected tot he OUT port and not through, right? and the cable is good?
If it says it is doing a bulk dump then the data coming from the Electra to the PCM is good.
If nothing happens on the Electra, then either the data isn’t getting there or is rejected by the Electra.

When I get home today, I’ll hook up the PCM 81 just to verify I didn’t break anything trying to maintain compatibility.

Other question – do you have any cards plugged into the PCM 81?

Sanity, check! Cables are good (IN/OUT, nothing connected to THRU).

So grateful for your time! Nothing about this is urgent for me, so please don’t put yourself out on my account…

Sorry - forgot. I do have a DualFX card inserted in the PCM at all times.

Well, it’s kind of a fundamental thing, so I need to eventually figure out why users have connectivity issues and how to either work around typical things or better inform a user what might be the issue.
The Dual FX card shouldn’t be an issue (I’ve been testing with and without but not recently).

If you’re comfortable with the Electra web UI, when you have the browser open and have sent the PCM 80 preset to your Electra One, you can click on the Edit button.
That gets you into the next level of things.
Near the top will be a row of icons. Click on the Tools (screwdriver/wrench crossed)
You should see a new row of icons including a Bug icon.
Click on that.
Now you have a debug screen open. In the upper right is a Triangle (arrow).
Click on that to (re)send the PCM preset to your Electra hardware.
You should see some messages in the debug window.
Once it finishes transferring (it does take a bit), Press the Sync button on the Electra One PCM preset and see what comes back in the debug window.

That would be hugely helpful in helping me figure out what is happening.

1 Like

attached is a series of screenshots on how things should work - just did it with my PCM 81 w. Dual FX card. It shows opening up the debug window to get info. unzip and view in order 1 → 6 if needed.

pcm80_steps.zip (230.3 KB)

1 Like

Ok, I tried this and the result was this screenshot. (nothing happened after pressing SYNC.)

Tried a few more times - twice, the results looked like yours…
But, pressing SYNC still does nothing.

Do you have other presets loaded to your Electra? From the web UI, go to the controller screen and delete all the presets listed, even the PCM. See the Electra One docs in the Preset Library section for the screen I’m talking about.

Then reload the PCM

Very odd. I’ve seen that one in a great while, but never could say what causes it

First of all, thanks for that screenshot. I was responding from my phone last night, so limited time/space for a reply.
If anyone else runs into weirdness, this type of screen capture is really essential for any developer trying to figure out what might be happening.

The screenshot implies (to me) that there is some kind of memory corruption or stack overflow happening when the preset is first loaded.
Hopefully @martin can look at it and maybe see what is happening when it is sent to the Electra One.

Other things to try – send a few different presets to your E1 and then send the PCM 80 preset.
If it is a memory/stack issue, that may have randomized the memory enough to allow the PCM 80 to load and run.

Not sure if posting a version with the debug prints and comments stripped out will help; Let’s see what happens with your next round and if Martin responds as well.

Thank you! No, no other presets were loaded. I did delete the PCM preset and loaded a Strymon preset (to see if I could get Electra to control something else, which it did), but then I deleted the Strymon preset and reloaded the PCM.

I’ll try your other suggestion later today.

Here is a stripped down version (not public)
Download it and give it a try. No bugs fixed, but maybe a bit smaller. So let me know.

stripped down PCM 80

Sorry, no change - ty for trying. Still takes a couple of tries for the Lua thing to not report an error. Also, the PCM still displays "“SysEx data error” upon any knob twist. For the record, I did reinstall the Electra’s firmware, just to rule that out.

I’m beginning to suspect there may be a fault in the PCM81 itself. It is, after all, nearly 3 decades old…

Many thanks for your efforts…