Pitch Bend

I don’t think Electra currently supports pitch bend.

Pitch pend is sometimes used as a controller to give finer control over something.


In Logic Pro X I can’t seem to find a way of mapping anything other than CC7 messages to controls within logic. For the most part thats fine

But having only 127 values for something like a volume fader isn’t really granular enough.

Logic Pro X though will map volume to Pitch Bend messages as this is something that is used by the Mackie Control Protocol

At the moment I’m trying to use an Electra 1 in preference to a Behringer XTouch to control Logic

Maybe worth considering for a future update

1 Like

Glad you asked this. I’m a rank beginner with the electra.one, and fumbling about trying to figure stuff out. I was about to ask this - not only pitch bend, but also aftertouch - any midi message that isn’t one of the numerical ones. I guess velocity would be useful also. I’ve been trying to get pitch bend to work with midi learn, but nothing at all happens. Same with aftertouch. And I don’t see any mention of these in the docs, so I’m guessing that these messages aren’t recognized?

To be fair I can get why Pitchbend and Aftertouch are ommitted, they’re performance controls rather than programming controls both are generally used to modulate something else on a synth - with aftertouch that’s usually the filter and with electra you can already alter the filter so long as its exposed some way via Midi.

My particular use case is that Pitchbend is used by the Mackie Control Protocol as a high resolution method of controlling faders. Most DAWs have at least a rudimentary implementation of Mackie Control Protocol.

I’m really enjoying using electra as a control surface for Logic. I’m finding it quicker to use than my Behringer Xtouch with the added bonus of it takes up less space. If i can get high resolution fader movements sorted then the Xtouch will probably get sold. I’m even toying with the idea of getting a second electra - I’m finding it that useful

The reason for having them ommitted comes of the history. And it is not valid any more… At the very beginning, Electra was meant to be a synth programmer and I left the performance controls out on purpose - leaving the job either for the device (synth) itself or for a controller/keyboard connected to Electra’s USB Host port.

These days majority of users use Electra with DAWs, etc and these messages simply need to be supported. It has been already done on the low-level firmware. eg. Lua can be used to send and received all types of MIDI messages (of course, it includes the pitch bend, poly/channel aftertouch, song select, position, etc). What is left on the TODO list is to make a frontend for it and add it to the editor.

The Mackie Control Protocol is a perfect example why it is super important to get it in.


For Robin’s use case - would it be feasible, in the meantime, to use 14-bit CC commands and remap them to pitch bend in software? I know that’s possible using a Reaper/Plogue Bidule combination (maybe even Reaper alone but I use Bidule for all midi remapping), but not sure about Logic. Can control signals go through the Logic Environment before controlling what would be Mackie destinations?
There’s an AU version of Plogue Bidule that would work in Logic. Also stuff like the INsertPlz midi plugins, Midi Yoke, etc.

Logic is supposed to recognise CC14 but whenever I try it the electra locks up as soon as it receives a message from logic. I haven’t tried remapping pitch bend to CC14 that maybe worth looking into

Just to confirm on the 2.1 firmware electra still locks up when mapping a CC14 control to something in Logic using the Learn Controller Assignment functionality

this sounds like it would be better as a post in “Bug Reports”
perhaps with an example preset?

so you are saying if you assigned any 14 bit value to a control on the E1,
and send it to Logic, as soon as you move the control it the E1 locks up?

I assume this does not happen before you assign it to a logic control?

if so, my guess would be some kind of feedback loop…
ie. E1 sends 14 bit CC → Logic → Logic sends 14 bit CC to E1-> E1 → E1 sends 14 bit CC to Logic etc etc

if you look in logic and monitor the midi messages, do you see this happening?
what is being sent back?

I wonder if MSB/LSB is being reversed between the two…
or if logic is only sending back the LSB for small increments, and E1 is misinterpreting this.

it’d be useful to get some more details.

a couple of notes

  • I assume this does not happen with Pitchbend (see title), as Pitchbend is sent as one midi message.
  • it’s not uncommon for 14 bit CCs to have different implementations… unfortunately, the spec and the way they are supposed to work is a bit ‘lacking’

Yep will add a bug report

It’s very easy to reproduce. Set up CC14 control. Within Logic go to control surfaces and learn the electra control to something like volume.

The lock up occurs when Logic sends data to electra.

Happens irrespective of which way round MSB/LSB are set - I’ve tried both. Logic does allow you to specify which way round they are but seems to detect it correctly anyway

Interestingly I think its just when the electra receives a CC14 message from Logic regardless of whether it has a control or not. I mapped a CC14 control to a fader in logic. Got the lock up as expected. Within logic I changed the CC14 number to a different CC14 number but on the same port as the electra. So even though the electra didn’t have a control setup within the preset for that number it still locked up immediately upon rebooting when logic detected that it was connected and does a refresh of values. Which is suggestive that there is something about the CC14 message that the electra takes issue with

At the moment I haven’t tested Pitchbend as that is not currently supported by the editor - though I could hand code a preset.

CC7 works fine but the restrictive value range doesn’t make it ideal for setting fader positions or EQ frequencies. That issue aside I’m finding the electra massively useful with a DAW and am currently using it more for DAW work than I am for synth programming. Controlling compressors and EQs from the electra is really speeding up my workflow

1 Like

I played around with this and I had no problems with mapping and using CC14 with logic. From what you are saying I have a suspicion that it could be caused by the Mackie Control protocol messages. I will review that part now.

I am using Logic Pro X 10.6.3.

Do you have Mackie (or any other) control surface routed to Electra ports?

Hi Martin

I’m not at home until the weekend so will confirm then
There is certainly a Mackie controller attached to the Mac and configured within Logic. Data is sent directly to that and not to the Electra (I’ve previously used Midi Monitor to confirm but will double check). Possible some of the controls on the preset are copied from a Mackie setup. I know initially on the preset that I simply redirected within the Controls Surface setup some controls to the electra as I was attempting to duplicate the functionality. Again I will double check at the weekend. None of those controls though are CC14 or pitchblend - all are CC7.


I had a go at this as well…

7 bit works fine
14 bit, does NOT crash my E1, however ‘feedback’ does not work… and will cause logic to jitter a value.

however, this appears to be a logic issue…
whilst logic does send back a 14 bit CC, the LSB is always 0x74
so basically the E1 keeps resetting to MSB 0x74 as it gets feedback from Logic

you can get 14 bit to work in logic IF you turn on local feedback. (i.e. disable feedback)

Logic Pro X 10.6.3
E1 fw 2.1.0 , hw 2.0
midi monitor running on mac min iM1

p.s. I should say I do not use Logic that much, so perhaps an oddity on my side.

1 Like

There’s definitely something funny going on with my system that I can’t explain

Preset on electra with just 1 14 bit CC. No other controls
Electra is connected to Macbook directly with USB
All other control surfaces powered off
Logic Pro control surface preference file has been deleted. The rebuild defaults command has been used. I’ve even turned on the By Pass Control Surfaces option

If the electra is turned on and then Logic is started it immediately locks up. If logic is started then the electra is booted up It locks up as soon as the preset is loaded

Midi monitor is not showing anything being sent to the Electra. Just sys-ex coming from the electra as it boots

1 Like

odd indeed…

just to be clear,
you are using Logic Pro X 10.6.3?
also what mac model and OS version are you running?

also, just to ‘get it out the way’, I would try with a different USB cable … ‘just in case’

in logic midi preferences have you turned OFF - Electra One Ctrl ?
I’d do this - just so it doesnt try to process sysex from the E1.
(it didn’t really cause an issue for me, other than midi learn trying to pick up the sysex)

you said previous 7bit values were working - correct?
this is only happening when you add a 14 bit cc ctrl?

does it still crash if you turn on Local Feedback? (and/or feedback = none?)
this should prevent logic sending back cc messages, so you’d expect it not to lock up

is there definitely nothing going on in Logic’s ‘Environment’ , this could do all sorts of odd stuff, that wouldn’t necessarily be easy to see.

midi monitor should be showing the logic messages, as long as you have
source → spy on output to destinations - turned on (its off by default)
this would give a much better idea as to what is being sent to the electra

1 Like


Catalina 10.15.7
Macbook i9
Midi input is restricted to Electra Port 1. Have already tried different cables and different ports
Nothing has been setup in the environment.

Feedback has no effect. My understanding of the feedback mechanisms on Logic is that it refers to feedback being sent back to the device that has changed a value. It doesn’t stop logic sending messages back to the device when a project is opened or if the control is changed directly in logic with a mouse or trackpad.

I do have a reasonable amount of MIDI gear some plugged into a Mac. I’ve pruned some of that from Audio / Midi setup - just in case anything in there is causing a problem. I’ll see what more I can prune out but I’ve got a mix to finish for a client so it may have to wait for a day or two.

My gut feeling at this point though is either something logic is not sending out correct CC14 messages or I’ve got some detritus left over from some device or other that is causing logic to send incorrect or malformed messages to the electra.

Pitchbend to and from a Mackie control device though does work correctly maybe something is up with Logics CC14 implementation.

1 Like

what I dont understand is why its working on mine and @martin 's macs w/ logic
i dont think its logic on its own that is the issue… something else is also happening.

given its a laptop, id say first thing is unplug everything else except the electra one.
so its just the electra one + mac book pro and logic running, nothing else.

In the meantime I’ll try to install logic on my macbook pro which is running catalina…
(oh and I have an old imac I can try too)
but, honestly, I bet that will work… in the same way as my mac mini running big sur.


I’ve already been down that route, besides its all stuff that the electra has co-existed with for a while and in the main is used to program. The mac book is only used for music purposes, it’s pretty lean in terms of other peripherals (and software) attached to it and the majority of music equipment is largely attached via a midi interface (which is currently detached to rule out midi loops)

At the moment , my money is still on Logic. Apple’s documentation on setting up controller assignments in expert view is pretty scant. I’ve got a feeling that one of their updates has upset the CC14 implementation in that area

In terms of the tests that you Martin are running (and I’m grateful for). In addition to changing a value on the electra and seeing if that change is propagated to logic you need to directly control the control in logic so it sends something to electra. It’s that bit that I think is the cause of the lockups. Map something like a fader. When I map that to CC14 electra doesn’t control the full travel of the fader (it loops (which is suggestive of logic not parsing the CC14 value correctly), moving the fader manually then locks up the electra. Once locked up I get stuck in a cycle of lock ups until the CC14 control is removed or unmapped.

I need to uninstall some software as something from SSL has installed allsorts of virtual midi ports which seem to be send out mackie messages to this that and the other - even though that there is no current mackie config. I don’t think that’s the source of the issue but it’s adding to the general confusion at the moment.

1 Like

Could it be the LSB first option in Electra One? Maybe Logic expects a certain order to the two CC’s needed for 14-bit resolution?


Tried it both ways. Also tried opposites. ie Electra sends MSB first but logic expects LSB just in case someone got their logic the wrong way round

1 Like

Yea, bummer, it would have been too easy a fix :wink:

1 Like