RelCC 2sComplement knobs change value range after page switch

Brand new Electra One MK II owner here (first evening playing). I primarily bought the unit to use with the DrivenByMoss Bitwig extension.
I have:

  • Electra One Mk II v3.0, firmware 3.6.0 (pre-installed)
  • DrivenByMoss Bitwig extension and E1 .eproj file v23.2.1

The bitwig preset is working 100% OK if I reset the E1 unit, and use the faders on the first preset page (Mixer). can see the E1 knobs are sending on MIDI channel 16, CC 10, value ranges 1-2 (turning CW), and 125-127 (CCW)

BUT, after changing page on the preset (e.g., to “device”), any knobs that I moved on the first page no longer transmit the same value ranges back to Bitwig . they now transmits 102-103 (CW) and 97-98 (CCW). The translated values are now all wrong and the bitwig controls do not respond.

Knobs that I had not yet touched on the first page work OK after the first page change. But as soon as I change page, those knobs also no longer send the original value ranges either.

Once this happens, the only way I have found so far to restore operation is to reset the E1 device.

I had a look in the DrivenByMoss eproj file … it seems all the faders are mapped as relcc twoscompliment relative controls:

 "values": [
          "id": "value",
          "message": {
            "type": "relcc",
            "deviceId": 16,
            "parameterNumber": 12,
            "min": 0,
            "max": 127,
            "relativeMode": "twosComplement",
            "accelerated": true
          "min": 0,
          "max": 100

Not sure if this is related, but I also cannot get the new DrivenByMoss multi-touch combinations to work either.

I thought I would post something here first in case this indicates a wider issue with the 3.6.0 firmware rather than the DrivenByMoss preset or script. I don’t have access to a previous E1 firmware to see if that is the root cause.

The E1 hardware looks just great - love the screen and feel of the controllers!

UPDATE 15 April 2024.

I just tried flashing the previous v3.5.4 firmware onto my Electra One MK II. The relative CC knob MIDI value ranges still change after switching pages as I reported above with the 3.6.0 firmware.
However, the multi pot touch page-switching behaviour does now work.

I then flashed the v3.5 firmware onto my Electra One MK II. No difference to v3.5.4 behaviour - after changing pages, the relative MIDI knobs change their output value range to 97 - 103 instead of 0-127.

I am now stuck. The DrivenByMoss preset is designed for " * at least Firmware 3.5 is installed on the device.". But it doesn’t work for me on my new Electra One Mk II with either 3.5.0, 3.5.4 or 3.6.0 (where the multi touch no longer works either).

I would be very grateful if someone else who is running the Bitwig DrivenByMoss preset on a Mk II can confirm if they experience the same behaviour ?!

I am looking at it now. If needed I will ask @moss for help.

1 Like

@Phommed can you try to reimport the drivenbymoss.eproj file to the webapp and send it to electra controller?

note, make sure the original driverbymoss is removed from the controller. you can do that by overwriting the same slot or by using Controller::preset slots to remove it.

Hi @martin ,

I just tried deleting and re-importing the 23.2.1 DrivenByMoss preset onto my E1 … and the knobs now work after page switching! I can see the relative MIDI values remain in the nominal range 0-2, 125-127.

The DrivenByMoss multi pot touch switches are still not doing anything (running on E1 firmware 3.6.0) but I guess that is a different issue with the preset and the new firmware.

I will test more this evening, but looks like we can close this specific bug thread as solved - thanks so much.

Is it generally a good idea to first delete an existing preset from the E1 device before re-uploading a new version ? The knob value changes was a strange behaviour.

1 Like

I know the reason why it is happening but I need to discuss that with moss first.

The safest way is to:

  1. stop bitwig (it will deactive preset)
  2. delete the existing preset
  3. upload the new new preset
  4. start bitwig
1 Like

Hi @martin. I just upgraded my E1 to the new 3.6.1 firmware, and the DrivenByMoss extension multi pot touches are now working - thanks for the fast fix!
Not sure how to mark this bug request closed, but all looks OK to me now.

1 Like