[Solved] Preset loss in online library after renaming the title

Hi there,

I just updated my new preset (Sonic Potions LXR 01 Drum Synth (BC0.37)) and wanted to change the name of it. It then went totally empty and the title also disappeared. I tried to change the title to the old one but it stays empty.

Any chance I get the work back? I still have the preset on my Electra One and can see it in the Console app when selecting it… saved that to a txt file.


how did you save it to a text file? what does that file look like?
I didnt think the Electra One Console has a way to save a preset?
(it would be a good addition!)

I looked at the one on the website, and indeed that is empty :frowning:

ok, some good news…

it is possible ( as you can see in Electra One Console) to get the preset using sysex.
you need to send it ( on ctrl port)

0xF0 0x00 0x21 0x45 0x02 0x01 0xF7

you then need something that is listening to the CTRL to recv the sysex.

then you will see the JSON file that represents the preset, which could then be saved and uploaded to the web editor again.

I’ve created a small (command line) app that runs on macOS that can send the relevant sysex and dumps it to a file.
I just need to build it , if its useful for you.

1 Like

Hej technobear,
thank you for the quick reply!

I went to the preset page on the Electra and selected the one and than copied the log data from the console app into a .txt. But its not a json format…

So I will try the sysex command… maybe with sysex librarian.

Cool - bare in mind you will also need some kind of midi monitor to read the sysex that the e1 sends back.

Hi @thetechnobear again,
I’m stuck with my little knowledge on sysex… just looked around: Sysex librarian cannot send sysex messages, it reads sysex data from the hardware.

I tried midi pipe to send the sysex you send me, but it had not the length of your sysex message.

Is there an easy way to send the sysex commands on macos? If you can build your solution in a minute I’m happy to use it in my terminal…

Ah, found a way on gearspace:

Use terminal:

echo -ne “\xf0\x00\x21\x45\x02\x01\xf7” > getpreset.syx

Then send those files with sysex librarian.

But it didn’t work.

heres a link to the sysex file


Thank you. I now have a .syx from the Electra.

The bad thing is - I pressed the write button in the sysex librarian and now my preset is overwritten on the electra…

Don’t know, if I can get the .syx into .json or anything… :expressionless:

if you want, you can post the sysex, and I’ll take a look at it…
basically you should see the json… ,detailing things like ctrls.
(back it up first, then just look in a text editor)

The .syx looks like this:

Thanks! The file is here:

If you get it to work you make my day :smiley: But don’t stress yourself… I can build a new preset also.

Maybe I corrupted it by the long title… That was the last change to the preset…

lxr_electra.epr (175.2 KB)

WOOOW :partying_face:
It worked. I have it in my library again.

Big thanks from Berlin!!!

1 Like

Did you convert it into another format? Renaming the file did not work for me…

you need to edit the sysex file as a text file.

then remove characters before the first { and the character after the last }
(leaving the braces)

thats it :slight_smile:

I just formatted it , because i wanted to check it was ‘roughly’ correct before handing it back, but thats not necessary

1 Like

Ah… will save that info for later.
Thanks again for helping out!
Some hours of tinkering rescued :pray:

I will clone/download my presets in the future to be safer…

1 Like

@tomas is now on his vacation. I will talk to him about it when he is back. The presets are stored in the cloud and we take regular backups. Recovery is of lost data possible.

We will check why the preset disappeared. Sorry for the inconvenience.

Thanks @thetechnobear for providing help.


It would be useful if the Console app could also save the current (on E1) preset to a file.

useful for doing backups… and also as we have load preset on the console app, allows for a degree of autonomy from the website.


Yes to more ways to backup directly from the Electra in case of Murphy hitting again :slight_smile:
@martin @Tomas I deleted the empty preset in my library but maybe you can still find it in your backup files.