Troubleshooting documentation page?

I have a hint for improving the documentation - also see my post at SOLVED: Mk2 Firmware 3.5 Always boots to logo and stays there, but the default preset is fine - #7 by henning

I tried to fix the boot problem I had by forcing an upgrade, because the page tells this as the most likely source of boot failure.

But I had some issues with that and when it looked successful, it still didnt solve the problem and because tings looked all a bit strange(see below), I tried it multiple times with the same result.

only when I came here to report it as a possible bug because i was unable to boot my electra, i learned the boot-to default trick…

Maybe there are other tricks like this, and maybe it would be good to collect them in the FAQ or in some “troubleshooting” section in the docs.
This could have saved me quite some debugging and trial/error time…

additionally, when I tried to do the forced firmware update, the link to the firmware on the page Firmware update Electra One mkII | Electra One Documentation wasn’t working, I got 404. only the download link at Electra One firmware | Electra One Documentation worked - for some reason they have the same content inside the zip, but are not the same zip filename… today both work again, but I am sure a week ago or so the first one didnt and it took me a while to find the other, working link.

By the way the preset that does reproducibly lead to this boot problem is the mioXL preset.

And also, I had the same problem with unmounting the electra, on macos monterey - I had to just pull the plug/reboot the E1, then the mac complains about not proper unmounting.

Also, in one or two of the multiple times i tried, “ls” in the terminal as well as the electra one showed a strange firmware name in the boot directory and in the menu, something like ._controller.srec or so - looked very confusing.


The troubleshooting section has been added to the docs. I will keep adding new articles there as the repeating issues occur.

Troubleshooting docs

the ._controller.srec is created on the filesystem by the MacOS. It is a file with MacOS specific file attributes. Starting firmware 3.5 these files are automatically removed during the system boot.

1 Like