SOLVED: Mk2 Firmware 3.5 Always boots to logo and stays there, but the default preset is fine

I updated the firmware to 3.5 of a mk2, and now everytime it boots, goes to the logo. I have to press the top left button with a reset to be able to boot correctly, and then, choose the preset I want.
I tried to re-upload the firmware, but this happens with 3.4 too!

As a note, on MacOS 13.4 (ventura) there is no unmounting the E1 drive, it just does not want to unmount!


Can you post the preset?

It happens with any preset! Actually, a selecting my blank slot 1 freezes the electra.
Is there any way to completely clean install the Electra mk2?

1 Like

This is driving me mad. Even if there is no preset at all, and I delete all, it just freezes. I think the preset handling aspect is causing the crash. I really need to completely wipe all the presets, even the empty ones.

1 Like

I never imagined anybody would write 4000+ lines Lua module for E1 :slight_smile: Impressive and exciting! The issue is dealt on PM.


This has been Solved. Thanks Martin!

For reference:

  • window.stop was called
  • lua may halt the interpreter due any problem and never reach the window.resume()

And this way, it was not refreshing anything ever again.

Thanks for posting the solution with the top left button!

I had the same problem, and the trick with pressing top left button at reset helped me.
I have not found this trick in the documentation, actually it has no section for problems/solutions or similar.

It could probably be documented somewere in the docs then just in the forum - maybe the documentation and/or the FAQ could have a list with troubleshooting / rescue commands.

That would have saved my trying to reset/reinstall the 3.5 Firmware 5 times

1 Like

It’s 25k lines now! However, Im coding stuff on the computer to avoid the back and forth to the E1 reset-mounting drive-reset to use code as proper lua modules. Hopefully soon there is a way to upload modules into the drive.

1 Like