Ubuntu/Chrome connection problem


So I have my Electra mk2, it’s connected with the supplied USB cable and I’m running Linux OS Elementary 6.1 with Chrome as the browser. I’ve run amidi -l in the terminal and the electra ctrl port shows up, I can select electra ctrl in Chrome where it says to select the ports manually but that’s as far as I can get, nothing else happens. The E1 appears responsive to knob movement.

Where do I go from here? Thanks

1 Like

Hi @stratblue,

some Linux distros keep the limit of the max size of sysex messages very low. I suspect it might be the problem. To start, you might want to increase that limit. You can do that by reloading the snd_seq_midi module with new buffer settings. There are more ways to do that this is one of them. Using sudo or as root run the following commands:

rmmod snd_seq_midi
modprobe snd_seq_midi output_buffer_size=262144

Let me know if it helped.

Hey Martin.

I’m new to Linux so I could easily get stuff wrong, I ran both those as sudo but no change.

Chrome Version 114.0.5735.90 (Official Build) (64-bit)

Any other suggestions?


1 Like

Do you have a chance to connect the unit to other computer that runs windows or macos? Just to confirm that the controller works fine. Then we know that it is something related to Linux.

I have a spare Intel NUC here. I can try to install Elementary 6.1 on it and give it a try by myself. Not sure if I squeeze it in today, but during the weekend for sure.

I do believe that @C0d3man got it working on Linux. @C0d3man: is that correct?

You can also send me my Mk2 and I can help testing… :innocent: (I’m using Ubuntu 99% of the time and I have a Windows partition just in case.)

1 Like

I can connect from a Mac but it says it needs newer firmware (3.2), when I press ‘update firmware’ it wants to connect to a HID device but says ’ no compatible devices found’. Chrome on Monterey.

One more thing you can try:

Open any type of MIDI monitor application on Linux (eg. https://kmidimon.sourceforge.io) and check if the CC messages are sent out when you turn the knobs.

I have been sending CC from out 1 to a Blokas Midihub, seems fine to me.

Just an update for whoever is following the thread. @stratblue and I have been working on the chat to see what is happening. The controller sends messages just fine but the app.electra.one does not pick them up ok for some reason.

1 Like

I installed Elementary 7.0, latest Chrome. It works fine. For larger presets, adjusting the sysex buffer size was needed. Let’s continue our communication on the chat.


For those of you who use Electra One on Linux. A good way of setting the MIDI buffer sizes is to add the parameter adjustment to the modprobe configuration. There might be slight differences per distro, but in general adding the following line to alsa related config in /etc/modprobe.d/ will do the job:

options snd-seq-midi output_buffer_size=262144

This ensures that the buffer size is set when the alsa modules are loaded, either automatically at the boot time or when loaded manually.

Also, note, this adjustment is needed for the Chrome browser. Chrome seems to dump whole SysEx messages to the MIDI driver, not decent sized chunks of them. It is not much related to the E1 hardware. Other MIDI applications may work just fine without making any changes to the buffer size.



i just tried with Ubuntu 23.04 (amd64) and…

  • Firefox 113.02: No success
  • Chromium 113.0.5672.126: No success
  • Chrome 114.0.5735.90: YESSSS!!!

And I just tried on Raspian (Debian 11 bullseye) with Chromium 113.0.5672.95 (with setting the options from @martin Yes, works also - but a little bit slower due to the smaller CPU :slight_smile:

echo "options snd-seq-midi output_buffer_size=262144" | sudo tee /etc/modprobe.d/midi.conf
sudo rmmod snd-seq-midi && sudo modprobe snd-seq-midi # Close browser tab/window connected with E1 before

Regards, Holger


Ok, it was my turn to his this problem. :slight_smile: I can connect to the E1 and touch configurations but I can’t send presets. (I cheated using the Windows partition I have for this kind of situations.)

@C0d3man I’m also running Ubuntu 23.04 and a recent Chrome version. Can you explain what you do with the commands above? Just run them with sudo or add them to some config file?

And is this solution better than this other one above or just the same solution adapted to Ubuntu?

One clear answer for dummies will help me and everyone else inevitably landing in this topic later. :slight_smile:

Ok, let’s go…

echo "options snd-seq-midi output_buffer_size=262144" | sudo tee /etc/modprobe.d/midi.conf

This line appends a configuration line to the file /etc/modprobe.d/midi.conf (or creates the file if it not exists) with the right of the root user. In /etc/modprobe.d/ there are configuration files located which are used when a module (in our case snd-seq-midi) is loaded. The output_buffer_size is set to 262144 bytes which seems to be needed for bigger dumps of a preset.

sudo rmmod snd-seq-midi && sudo modprobe snd-seq-midi

This line simply removes the snd-seq-midi module and if this was successful it loads it again (but now the previously created configuration files is used).

It’s the same, but the first version is permament (only needed once) and the second one is temporary - after reboot or reload the module without the options the “normal” state is restored.

Hth, Holger

1 Like

YESSSSSSS, it works! Thank you so much, @C0d3man!

1 Like

So… I have installed Ubuntu 23.10 fresh, and I am having trouble connecting the E1 again. It’s strange because the website says it is not connected but something is connected.

The banner is not the default:

And PipeWire sees the E1:


I have followed the instructions above. /etc/modprobe.d/midi.conf has that line, and I have also rebooted the PC just in case. Still no luck.

EDIT: Bitwig detects it as well, and I can run Moss’ extension. Apparently it’s only the website that has a problem? MIDI Thru works as well.

EDIT2: Yes, I have given MIDI permissions to the Chrome browser.

1 Like

I also have been having problems on Linux with Chrome. Firefox worked however.

1 Like

This is good news because I’d prefer to use Firefox for this. However, the browser doesn’t respond when I click the button. I have Firefox 118.01 for Ubuntu. It’s the snap version. No idea whether the deb package version would make a difference. Sometimes it does.

I am actually also having problems on my machine right now. Both with Firefox and Chrome.

What kernel version are you using?

Edit: I did some testing on Firefox and it seems that smaller presets can be sent and larger presets cannot. This has been working before so I think an update broke it some time.

1 Like

Linux quiet 6.5.0-10-generic #10-Ubuntu SMP PREEMPT_DYNAMIC Fri Oct 13 13:49:38 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

I found someone else reporting something similar, not for Electra but for Novation Components, which is similar to the Electra editor in the sense that it runs in the browser and is using Web MIDI.

1 Like