USB Disk mode not working any more in Win11

I just wanted to load 3.5, but the Electra One mk2 is not showing up as a drive any more in Windows 11.
Sometimes I get a message that the mounting is too slow, sometimes the drive shows up, but it’s empty and powershell says that the drive does not exist.
The disk management panel is showing a 4GB removable disk which is unallocated.

There is no error in the Device Manager and the device is recognised in the browser, telling me I should update to 3.5.

EDIT: Works fine on Android. Was able to update the E1 from my phone.

Are you using a USB hub or a direct connection?

I’ve tried both, even a TB3 port and different cables.

Works fine with Windows 11 here

I am getting this same issue on Win10. After updating to 3.4, now when I boot into bootloader and choose USB disk enable it shows a drive popup but its greyed out. Was using the same usb port but also tried different ones.

@buyallthecontrollers @Fearmo I will reach you on the PM. I would try to reinstall the bootloader with you to see if it makes any difference.

@buyallthecontrollers - I think we did it together at the very beginning of the MK2 project, didn’t we?

Is there instructions on how to reinstall the bootloader. I might be being stupid if it is listed somewhere. I have faith I can do it if I have instructions

I think we did it together at the very beginning of the MK2 project, didn’t we?

We did!
Is v31102 still the latest version of the flash programmer?

The instructions are not online on purpose. Making a mistake during the bootloader update may result in bricking the unit. If we do the procedure on the Chat / PM, it should not take longer than 20 minutes.

I suggest I’d will do that with @buyallthecontrollers first - he has one of the very first mk2. He did the bootloader update already and has all the software. If it resolves the problem, I would do that with you too and possibly shared some extra info.

Also note, I am working an making it possible to update the controller directly from the web browser. mk1 users are familiar with it and it is super convenient.

I have just finished a session with @buyallthecontrollers. It is not a bootloader problem, it looks like something does not go ok with the device (E1 disk mode) migration when windows 11 are updated to the latest 23H2 update.

I am updating my windows computer now to (hopefully) replicate it on my side.

Thank you @buyallthecontrollers for identifying the cause of the issue!

K Martin I will wait…but FYI I am on Win10 but I did recently update my machine with the latest update. Worst case maybe I will try to update on my work laptop even though I shouldn’t :stuck_out_tongue:

One of the windows updates in the past enabled Core Isolation that caused problems with some drivers so I’d probably look at the security features first.

1 Like

This sounds like it could be the issue. The device manager complained (on @buyallthecontrollers) about enabling or loading the device driver I think.

I tried to update to the latest version but windows says:

I guess I need to wait a few days.

I also tried to enable Core Isolation feature on the current system, but I get:


@Fearmo @buyallthecontrollers would you review and possibly test to adjust the Core Isolation settings in the Settings :: Device security?

@martin - Core isolation is not available on this PC and I also don’t use secure boot.

1 Like

Also, you can force download updates:

Seems more involved than the typical upgrade though.

1 Like