Ableton Live MIDI Remote Script / Control Surface

Yes i know, i have very specific needs (it seems) . but like a lots of artistic projects . That’s why i love the E1 :grin:
His power is in his versatility , the fact that it can adapt and be customized way far beyond most of the midi controllers. Way far beyond most autonomous midi controllers !
Your script is for me the first step for most of Ableton users to integer it in their template in a straighforward maner . and it’s a good way !
Still , like lots of people and more for artistic or creative one , there is always something they want that differs from what the device is made for.
They see that “it could do it” .
For most of the controllers , it definitively can’t be done in a simple maner. then we try every accessible maners to do it . And for a lots of users, customers, it’s limited . Because of the lack of time or knowledge… and time :wink:
It took more or less time . sometimes it works , sometimes it does not work .Sometimes we give up.
But we learn and adapt and accept . :blush: . And sometimes the boundaries are pushed back .

I have to Admit that E1 is the first controllers since a lot of time where i see no immadiate boundaries regarding the manipulation of midi . because of the LUA, his touchscreen , the knobs, the app to make templates, the number of midi controllers accessible . and his customability ! .Even if i does not code, i copy paste many of the simple function to customize the E1 in my own need. Like a Lemur but with Real knobs ! AND THERE ARE SPRITES !! I LOVE SPRITES !!!
I am so happy ! sorry for talking so mutch .
All that to say . Thanks Jhh for already adpated your script to include also a part of my special needs ! Thanks to make the E1 more accessible for lots of futur customers !
I will definitively make a try !
Have a good evening !


ok with the latest version of altmixer it’s much better … sorry. Thank you very much sir!

It is true that the idea of development of this script are multiple.
A dedicated Topic would be nice to avoid flooding @jhh 's work.
For me, a fluid personalization via App E1 would be top and… stop…
I think after the launch of the MK2, @martin will have more time for ingest.
Be patient

1 Like

No worries. Glad to be of help

1 Like


2 questions …
…the “own look” “preloaded device” worked once, but now it doesn’t.

  1. Ableton Live has a Komplete Kontrol. there are Macros for the parameters. Macros are also displayed on the interface of the scipt plugin device,
    the “Komplete Kontrol” ccmap and epr files are displayed in the “dump” directory. I import the epr file into E1. the name of the preset will be “Komplete Kontr” for some reason. I change the color of a “controller”, send it to E1, everything is fine. I download the preset, change the name of the file again to “Komplete Kontrol”. I copy the “Komplete Kontrol.ccmap” file from the “dump” folder and the downloaded “Komplete Kontrol.epr” file to the Script “preloaded” folder.
    I run the “makedevices” file in the scipt folder. it says everything is ok.
    I restart the E1, Ableton, load the project. I click on the Komplete Kontrol track, which has the KK device that was “dumped” with the Macros, but the color I modified does not appear in the plugin device window. what is the reason of this ?
    my other question is how to copy a modified dump file (such a color and layout) into an existing preset so that it works?
    if I simply copy the controllers of the modified dump file into the already existing preset, unfortunately it does not work.

Probably the reason is that the trick to get the name for a plug-in changed recently. The name is derived from the enclosing rack, but now an additional hyphen is added. Some “Komplete Kontrol” becomes “Komplete Kontrol-“.

…then what should I do to make it work well?

Add the hyphen to the name, I.e. “Komplete Kontrol-.epr”

is it okay if I rename it in the finder? or should I save the E1 preset with this name?

does not work. after importing the dump file (why is the name of the preset not complete after import?) , I renamed the “Komplete Kontr” preset to “Komplete Kontrol-” with the E1 editor and downloaded it. I also renamed the “dumped” .ccmap file to “Komplete Kontrol-”. I copied both files to the “preloaded” folder, “makedevices”, restart,…unfortunately it doesn’t work.

Can you set DEBUG=6 in, try again, and then send me the log file? (See the for information on where to find these.)

I sent it in chat :slight_smile:

Hi There, just wanted to let you know that the preset no longer seems to automatically pull the parameter values for the mixer and devices in Live 11.3.2 on Windows 11, but the presets still control everything correctly. I haven’t checked whether this is true on Mac yet but I can do so soon!

Ok, let me know what you see on MacOS. I am not on 11.3 yet, and also away from my Windows machine so cannot check.


Hmmm I tried the windows machine again and suddenly the controls automatically read the Ableton values now! Hopefully it was just a bit of weirdness on my end!

I have been testing the Ableton Remote Script on mkII and I ran into problems with opening the Device preset. The remote script keeps reloading an empty preset instead of showing the Device preset. At some point I connected E1 mkI and I had the same issue.

Midi Monitor reveals the following:

I am on Ventura 13.2.1, Live 11.3.2, and the latest version of the remote script from the GitHub.

This is happening when using the remote script without the sendmidi. With sendmidi, everything seems to work just fine.

Is it just my computer or anybody else has the same problem? Or have I missed anything? Thx!

It looks like the ACK is not properly received by the remote script. In that case it thinks the preset is not properly uploaded and keeps on trying. This could be caused by a port configuration mismatch

Thanks @jhh. When I change to use sendmidi it works fine. Also, MidiMonitor indicates that the messages (sent from Ableton) are broken and all are 256 bytes. I leave it for now, but currently I am unable to use the remote script without sendmidi.

A that, yes I 've seen this many times before also on earlier versions of Live on MacOS only. To be honest I do not understand what’s happening, and I’ve searched the web in vain many times for ideas.

What I see is this.

  1. First of all, it appears sending large sysex through Live under MacOS is much slower than under Windows. Under Windows it is as fast as using sendmidi under MacOS.

  2. Looking at the logs, what appears to happening is that a large SysEx is not sent fully (and is cut off at a multiple of 256). The remaining bytes are then sent (much later) in chunks of 257 (as reported by Midi Monitor) bytes. Because the sysex is not sent fully, no ACK is sent by the E1, and at some point the remote script assumes the send failed. It then proceeds doing other stuff (eg update display values for the mixer) sending other messages to the E1 are then sent even earlier than the remaining chunks of the truncated sysex. (But see below)

One question: I see on your screenshot that you get exact timings for sysex messages sent to Port 1 in MidiMonitor. And it appears you do not have any specific sources etc selected (top part). When I run MidiMonitor I get ‘0’ as the time sent for a SysEx to Port 1, and messages appear to be shown out of order. Any idea why we see things differently?

P.S.: Did the logic for forwarding ACKs change with firmware 3.2? If I attach a second E1 to the first and forward sysex to the second E1 from the first, the ACK sent by the second E1 is now forwarded by the first E1 back to the host. Was this always the case??? I noticed uploading presets failed in CONTROL_BOTH mode, which apparently happens because then TWO ACKs are sent instead of one when sending a SysEx to the second E1 with the mixer. BTW, when reverting to CONTROL_EITHER mode, I appear to be able to upload large presets to the single E1 just fine through Ableton Live (without sendmidi) although it is still very slow.

Ok, clear. There was similar issue with Bitwig, but they implemented a fix to support larger sysex messages. I am not sure if Ableton will do the same :slight_smile:

hmm, I never had problems with the timestamps and order of messages. The Midi Monitor is not really reliable since the Core Midi update in BigSur though.

The MIDI sources - I work now with E1 connected to a JTAG debugger, the controller halts immediately when I stop the debugging session. It disappears from the list of MIDI devices immediately.

hmm, I do not think this has changed recently. But, if the ACK etc is transferred on the CTRL port, it should not be forwarded. If it is on Port 1 / Port 2, it is considered to be an ordinary message and it will get forwarded. I wrote this statement without verifying the code, so I might be wrong :slight_smile: I will check that later. I will be working in that area of code soon.

Note that Ableton sends large sysex just fine as long as there is no interference during the transmission.

Let me know once you have the definite answer. If I understand correctly I have no control over the port over which a second E1 is connected to the first E1, right?