ADDSR Envelope

Not sure if this is a bug or if is a feature request:

In this thread I was exploring how to achieve a visually satisfying envelope for an update to the Korg EX-8000 preset…

I happened on the new ADDSR envelope. I was able to map things correctly when I locked Level 1 to maximum, then Rate 1 is Attack, Rate 2 Decay, Level 2 Break Point, Rate 3 is Slope, Level 3 is Sustain, Level 4 locked to minimum, Rate 4 is Release.

So far so good.

Here are the issues I have encountered:

For the Rate categories it doesn’t matter what the maximum is set to, so in my case as the EX-8000 envelope values go from 0 to 31, I would favor that.
For the Level categories I found that if I only set the max to 31 the Sustain didn’t reach the full height of the display, only when set to 127.
That seems incongruent.

The Rate values are inverse to the EX-8000: 31 is the shortest Attack and 0 the longest.
I would like that either changed or at least have the option to change that.

The labeling when called up and zoomed in on the E1 reads Level 1, Rate 1, Level 2, etc.
I find that not as useful as if I could relabel them with whatever I want.

As workaround this (lowest row) works:

The zoomed in look works well on the E1. The workaround version has issues with the Rates flickering and only the Levels working properly (judging from the animation of the envelope).

As well (like shown in the video of the other thread) the highlighting of the adjustable portion of the envelope when just touching the encoder is off: When I touch the Decay encoder the Sustain portion of the envelope for instance highlights, the Release highlights when touching the Sustain encoder, etc.

I think this pretty much sums up what I experienced with the new ADDSR envelope.
Please let me know if I just don’t properly understand how it is supposed to work.

2 Likes

@martin: Thanks for liking this. Is this something that you are going to look into at some point?
Thanks!

Yes, I will. I often use like to signal I read the message and I understand it.

1 Like

Thank you for clarifying! Just wanted to make sure! :slightly_smiling_face:

Ahh - I was thinking you just loved all the stuff we type here.

:grin: :grin:

2 Likes

It would be great if we could as well hide the controls of the envelope we are not using. In my case it would be Level 1 and 4.

1 Like

@eusti just a confirmation. I am already looking at that. The fix is coming in the upcoming release.

Hiding of unused controls - that is for later. It is not that simple as it might look.

1 Like

Wonderful, @martin! Thank you! :slight_smile:

ok, finally found a moment for this one. I read the message and there’s both - things that should be done differently as well as stuff that can be improved…

I tried and it seems to work as expected. You probably forgot to restrict the both the MIDI min/max and the display min/max?

All levels are considered. In your example you locked the L1 to 127. Other levels related to that. The highest level used is sets the maximum from the others. To test that, I set max of all levels to 31 (I guess it is the case of EX8000) and it seems to work fine.

This is on my todo.

That totally makes sense. I do not have time for working on it right now - but I will add it to my todo.

I will review that.

1 Like

Thank you, Martin.

What you suggested works. Not sure why I had trouble with the max settings before. Now that part works very well. :slight_smile:

Looking forward to the other changes to be made eventually. Thank you again!

1 Like

well, I think that the sidebar is too busy. Too many fields. @NewIgnis mentioned that earlier. You most likely just did not see the MIDI min/max settings there.

ps: btw I really like the idea of “locking” certain segments of the envelope by setting the min/max. I’ve never thought about using it that way :slight_smile:

2 Likes

Thank you, @martin ! It moves me that you think I’m contributing something worthwhile to the project and your thinking! So appreciated! And am very glad! :slight_smile:

2 Likes