Default State "On" for "Pad Toggle"?

I just tried to have a Toggle Pad in the default state “On” but it doesn’t seem to work as expected. To be sure it is not related to my SysEx command I tried with a pure CC Pad but after the synchronisation it shows set to “Off” on my E1 like normal. I even temporarily deleted all Lua functions but nothing helped.

Any ideas? Thanks in advance.

1 Like

hmm, strange I tested it on mk2 first. It works just fine. On mk1, however, the default state is ignored. I will look at it. I am planning to release an updated mk1 firmware this weekend, I will try to fix it before the firmware goes out.

1 Like

Thanks so much Martin. Another “off topic” thing that I just recognized recently is the following:

I use your “[Lua] Page switching” for all my presets and can’t remember any issues as I used to work with the E1 before a pretty long break caused by a lot of work with more priority.

Currently the E1 always calls up page 11 if I use your “[Lua] Page switching” example. In my current layout it calls up page 2 which makes it impossible at least for me to reproduce a reason. I tried to set a default page using some “Try&Error Lua dummy code” that I thought might work but it took me already too long without any result.

After each synchronization I need to call up my page 1 which I am currently working on which is a bit annoying. It would be also cool to set a dedicated page to call up after edits because when working on another page it is just convenient to always land on that page to check things and continue working.

I hope it makes sense and I didn’t overlook something.

@HaPe I just tried the [Lua] Page switching. It seems to work as expected. Can you send me a link to one your presets? I will check that for you. If you agree, send it as a PM or on a forum chat. Note, you do not need to make the preset public if you share the link.

Sorry to hijack HaPe’s thread, but since you’re planning to release a firmware for mk1, I just noticed a bug today using my Minitaur preset:
On the Envelopes controls, long press on a knob does not bring up the detail window anymore.
One’s has to use the [SECTION 1] button while holding the knob.

1 Like