Electra One with ProTools

Has anyone succeeded in connecting E1 through USB to a softsynth (AAX) in ProTools? I got the E1 to work in Reaper, Harrison Mixbus, MPC 2.0 and a simple VST Host program, but not in PT. I’m running version 11.something. It just doestn’t respond to anything coming from the E1, not even my simple master keyboard (connected to E1 MIDI 1 in).

Got it working, but I tried a few things. So it’s either:

  • Launch ProTools with the option “run as administrator”
  • This MIDI Thru setting under preferences, I set it to Electra controller:


I guess it’s probably the second option that fixed it.

1 Like

I’m sorry to say that PT still doesn’t like the E1 very much. While initialy I had it working with te above settings I had trouble in the last few weeks to get anything MIDI into PT. All other DAWS I tried have no issue whatshowever, but PT went even further downhill. No MIDI from any device could be sent anymore to a PT MIDI track, the meter would indicate no MIDI info received. I tried all the E1 ports, a Roland UM-One, a Focusrite 2i4 and a new MOTU M4. Even shutting down PT became a problem, it was no longer possible. The only way to close PT was through the taskmanager and kill the process. I reinstalled PT, the iLok manager, removed older plugins, started as administrator: no change.
I figured, let’s try to disconnecting the E1. Presto; everything back to normal, everything works again. I tried connecting the E1 but disabling it in the MIDI device option in PT, same result as before; no MIDI and can’t shutdown properly.

So it appears the E1 takes control of a MIDI specific thing which PT needs to function properly. As it is the E1 cannot really be used in PT, at least not in my version (11.3.1).

Btw, @martin I also tried to see if the “soft shutdown” option would make any difference, the key combo of right lower knob + left lower knob. But that doesn’t appear to be working anymore in the latest beta?

1 Like

Hi @SmartBits, I am not very familiar with PT, but I just installed it and made a few tests. I can see and record E1’s MIDI data no problem.

Tried CCs and notes. Track meter reflects incoming data.

Electra is a MIDI class compliant device. That means that the data is handled by the very same software driver for all DAWs.

This was on the macOS X. I will try Windows later today.

I believe most of the mentions I see in regard to MIDI and shutdown issues in PT are related to Windows machines, but I’m not sure. So it could definitely be a Windows only problem. And my version of PT is also not the latest, so it could be that they fixed it in later versions (which I’m not allowed to download). And it did function for a little while, not sure when exactly the problem started. I might go back to an older firmware on the E1 to see if that has the same result.

1 Like

ok, I can confirm I was able to replicate that with Pro Tools First 2020.9.0 on Windows. Electra is not on the of MIDI devices. I will contact their support.

Good to hear you can replicate it. I tried with the last of the regular non-beta firmware and the result was the same. I see it as just another argument to move from PT to another DAW… :wink:

ok, some progress… I think the issue lays somewhere in the fact that PT creates these [emulated] devices for Electra USB ports. I checked forums, quite some other controllers suffer from that in PT 11 and higher.

  1. Created own MIDI instruments for port 1 and port 2 in the MIDI Studio Setup

  1. I disabled Electra’s CTRL port in the MIDI devices.

  1. I am now able to view and record to Electra’s messages

No PT freezes, works just fine. A bit of magic though, I guess if I now enabled CTRL port it will just work.

I can’t get the workaround working for me. Set up the MIDI studio the same way:

But in Input Devices, the Controller is no longer showing:


The Controller shows OK in Ableton Live 10 Lite though (and probably the other DAWs as well):

And just after I post, suddenly it works in PT.

I begin to really dislike PT.

1 Like

Started playing a bit and then suddenly, out of the blue it just stops working.

I begin to really, REALLY dislike PT.

1 Like

I forgot to mention that in the MIDI Studio I mapped it as follows:

Electra Controller (emulate)  -> Electra Port 1
MIDIIN2 (Electra Controller)  -> Electra Port 2