How to control VST synth plugin (USB MIDI)

Just received my electra one and I have to say I am a little bewildered. Maybe I am missing something very obvious here but I cant even get the most basic thing to work. I would like to control Padshop in Cubase (or any other synth plugin for that matter). But no midi data from the electra seems to get to Cubase via USB. Whatever I do only the MIDI 1 OUT port shows any activity in the display. I looked at the web editor and all the devices I can setup only refer to the Midi (DIN?) ports but nothing refers to USB MIDI. So how do I send stuff to my DAW through USB?
Overall I think there needs to be way more documentation. Even the manual is very much hidden on the website.


Hey Kai,
good to hear that I’m not the only one having this problem :smiley: Just got my Electra and also can’t wrap my head around on how to send MIDI data via USB to my PC.

Hi there,

When Electra is connected to a computer with a USB cable, it provides three USB device ports:

  • Electra Port 1
  • Electra Port 2
  • Electra CTRL

Any message sent to “MIDI Port 1” is sent to both MIDI I/O DIN port 1 but also to USB Electra Port 1. The same counts for “MIDI Port 2”, messages sent there are forwarded to MIDI I/O DIN port 2 and USB Electra Port 2.

On certain versions of Windows or older versions of MacOS X, the ports are called Port 1, Port 3, and Port 3 (for CTRL).

I hope this helps.



Thanks for the info, @martin

Thanks for the info Martin. I think I had it setup like this yesterday and it would still not work. After I played around with it some more it seemed as if it did not like when the electra editor was open maybe? Anyway. I got it to work to a degree in Cubase for a bit.
Then however the editor told me there was a new firmware available, which I downloaded and installed. Now I am on 0.9.11 and now I can’t get it to work properly anymore. The electra does send out MIDI data but the CC range seems to be all wrong (wayyy too small). Also I have connected an Arturia Keystep to the USB input of the Electra. It shows up correctly in the display and also seems to be transmitting midi data when I hit a note. However Electra does not seem to pass these through to Cubase. No Midi data from the keystep arrives in the DAW.
I think I got it too work once with whatever firmware was on the machine originally but now I have no luck.
Also, despite being on 0.9.11 the electra editor is still telling me there is a new firmware out. Not sure if that is a just a message that gets displayed regardless of the version on the connected machine but it is a little confusing.


Hi Kai,

from what you write it looks like there is something wrong about the USB communication with between your Electra and the computer. The 0.9.11 and 1.0-rc8 firmwares are basically identical and the Editor accepts both versions. The fact that the “update firmware” message showed up suggests that the Editor could not read Electra version information (SysEx midi message is used for that). You should not be getting that message with either version of the firmware.

Please look at the article at Troubleshooting connection issues. What ports do you see there? Also, let me know what operation system you are using. If you have any MIDI monitor application, try to see if the midi data is transmitted. if you don’t, try

Regarding USB Host to USB port communication - it is most likely the same issue. Electra forwards USB Host midi messages to both USB device ports and USB MIDI DIN ports. Assignment to what port the USB messages will go can be set on “USB HOST” configuration page. (press right-bottom button and then “USB HOST”.

Kai, you can also reach me on the chat system in the editor. It would speed up the communication. I will be happy to arrange a session with you.



I’m getting the same firmware message from the editor. Did you find a solution to this problem? By the way, the Electra seems to be missing in the input list in the editor:

Hi @ColdSteel,

I am available on the chat in editor to help you with it. Would you join me there?

It is strange that you have USB outputs listed and USB inputs not present. Both inputs and outputs are propagated by the same USB Midi device.



1 Like

Problem solved by disconnecting unneeded MIDI gear, reloading the editor, selecting the correct I/Os in the editor and then reconnecting the gear. Thanks a lot for your help, @martin

1 Like

Hi @ColdSteel , have you had a chance to make any progress with Cubase quick control bindings? Is there anything I could help with?

Just wanted to share that one of the issues I was facing was to do with the Electra web editor and Cubase being open at the same time:
If I launched the editor first and Cubase after that, NO midi data was transmitted. If however I launched Cubase first and then the Electra web editor, midi data was sent from the Electra as expected. This is on Windows 10.

1 Like

It’s working fine, @martin however I didn’t have that much time to test things.

The issue that Kai mentioned still seems to be present, @martin

@martin, do you know a fix for this issue? Not being able to use Cubase and the Electra App at the same time makes editing presets a lot harder for me.

I aim at having this supported in 1.4. by allowing Editor <-> Electra communication on MIDI IO ports. ETA for 1.4 is before end of January 2021.


Nice, sounds great! Just out of curiosity: what’s the difference between E One and other gear that can be used in Cubase and the browser at the same time?

Bumping this one as I’m new to the EO and working through the various docs. I noticed on my PC Win 10 Live 11 setup for the Ableton VST preset, my preferences/midi setup looks like this

ableton midi settings

I don’t see this

ableton midi settings 2

Is ‘Electra Controller’ name replaced ‘Electra Controller (Electra CTRL)’ ?

1 Like


Windows do not read the port names out of the hardware controller. Instead, it just assigns the port numbers. The assignment is like this:

Windows port name → Controller port name

Electra Controller → Electra Controller (Electra Port 1)
Electra Controller (Port 2) → Electra Controller (Electra Port 2)
Electra Controller (Port 3) → Electra Controller (Electra CTRL)

The above screenshot was made on MacOS X, which reads the port names from the hardware.

Please note, Electra Controller (Port 3) is used for communication between Electra and the Electra Preset Editor application. You do not want to have that port mapped in the Ableton.

Thanks Martin for info - I wondered whether it might have been a Mac view. That’s now clear :smiley: