Electron Octatrack

Here is a preset for Elektron Octatrack (built for MK2 but should work on MK1 just fine). As we have no nrpn or sysex support on the Octatrack, its all built using CC7…
Enjoy!

Elektron Octatrack.epr (31.1 KB)

3 Likes

I’m patiently awaiting my Electra One to arrive and use with the OT. Can you send some screen shots of how you layed everything out???!

Its just like 4 or 5 pages - a channel strip, fx1 and fx2 controls and then a performance screen. We will be releasing an instrument file for the OT so you can create your own preset very easily just by dragging and dropping the controls you want and where you want them to be (as all the available/mappable controls are already in the instrument file)… If you want to see the present, I am using it here with my OT (not sure how visible it will be - all I have is an old gopro which is not the best one… :slight_smile:

1 Like

…I am sure you can load the preset to the editor (even with no elecra connected) and see how it actually looks like - it might be better than any screenshot…

Good idea. I’ve only tried to view the editor at work and the site is blocked. I’ll check it out at home. Thanks so much.

I noticed you didn’t map tracks 7 & 8. I wonder if this was on purpose or you weren’t able to. I finally received the E1 and can’t get midi learn to work in these channels.

Channels 7-16 are not being recognized by midi learn from my Octatrack or a Roland D-05. I see the MIDI IN flashing on the E1 screen but nothing happens in the editor. I have tried in a brand new fresh project and have checked the midi settings in the Octatrack. I reinstalled the the E1 firmware and tried again with the same results. Different usb and midi cables were also tried. Chrome is up to date. This is such a bummer.

I don’t own an Octatrack or a Roland D-05 but I’ve used the Electra One to control devices on channels 7 - 16 regularly. How is your equipment connected to the electra

Din connection via octatrack midi out to e1 midi in 1. I haven’t tried manually setting them up yet. The issue is with midi learn.

I’m currently creating a template for a device on channel 12 and have used midi learn successfully with that. Just checked and I’m currently using electra with 5 devices - all of them are on midi channels 7 or above and I’ve used midi learn to create at least part of a template for them each of them. Like I said I’ve no direct knowledge of either the D-05 or the Octatrack but its a bit bizarre that you have two devices with the same issue. I’d connect them to a computer and then using a midi sniffer to check that they are sending out the info they should be sending on the channels you think they are sending.

When you operate either of those devices on channel 7 or above does the electra flash its midi in to show it is receiving data

Please switch your Editor to Midi Learn and run the Electra One Console app. Electra reports detected MIDI Learn messages in the log file (so you can see them in the Electra One Console app):

Ideally you should see some messages like this:

348820 readMIDI: MIDI IO: received: port=1, channel=7, type=176, parameter=1, value=18
348867 readMIDI: MIDI IO: received: port=1, channel=7, type=176, parameter=1, value=21
348867 sendMidiLearn: msg=cc7, port=1, channel=7, parameter=1, value=18
348867 sendMidiLearn: msg=cc7, port=1, channel=7, parameter=1, value=21
348937 readMIDI: MIDI IO: received: port=1, channel=7, type=176, parameter=1, value=23
349438 flushMidiLearn: data flushed

The line with “sendMidiLearn” indicates that incoming message has been recognized. What do you see in your log?

I use octatrack’s channel 9+ for external midi sequencing all the time.

Same results with virus ti2 and Arturia keystep both of which I output these channels regularly.

I’m now noticing when twisting knobs on the E1 midi out flashes on screen but the parameter readout does not move. My unit must be defective. Ugh!!

Can you send me your preset? I will review it on my Electra. It is very unlikely that it was a hardware defect affecting only specific MIDI channels. Have you had a chance to look at the log file in Electra One Console?

Midi learn aside, I imported the .epr that is in the first post of this thread. Touch sensitivity and knob movement is being recognized intermittently on the hardware. I’m on the sites chat if you would like to talk there instead.

Midi learn sorted! Thanks Martin.

1 Like

Maybe worth saying how it was was resolved in case other users experience the same issue

A preset with device definition must be transferred to Electra prior to using Midi Learn. @mrcrappypants had devices set up correctly in the editor app, but the configuration was not uploaded to Electra. I will adjust documentation so that it is clearly described there.

Octatrack.epr (50.3 KB)
So, I created my own preset from scratch without using marek’s instrument file. I was hoping to get patch request capabilities added via the [PATCH REQUEST] button but I looked at marek’s epr in an online JSON editor and that is way above my head. Would anyone be willing to add it to my epr?

I use midi channels 1-8 for the audio tracks

From the OT manual:
HEX DEC CTRL PARAMETER TRN REC
$3D 61 Send request, 0 = all audio CC X