[Preset] Novation Summit/peak

Hi, based on @RobinC 's work, I’m now working on a Novation Summoit preset, according to the latest firmware revision V2.0.

I’ve worked my way through the osc’s, filter, envelopes and lfo’s. Fx, mod matrices and ARP are still to be updated to firmware V2.0.

Nevertheless it’s already useful as it is.
A new feature is the “Control select” in the bottom right corner, with which you change the MIDI channel used on all controls, so you can swap between the Summit’s Gobal channel, part A or part B.
So each control is tripled that way :slight_smile:

EDIT: V0.8 Patch select added, and the fx page has been revised to work with firmware 2.0
EDIT: V0.9 The 3 mod matrix pages have been corrected and updated to firmware 2.0


The Novation Summit has a distinct feature : a double ARP section, where both sections can play independently from each other. However, it is not that easy doing so, with only one set of buttons on the Summit’s surface.

No longer with the E1; take full advantage of the Summit’s unique ARP section :smile:
Introduced now in version V1 of the Summit preset.

I still need to tweak the controls a little to make the UX as best as possible for this preset, so all suggestions are more than welcome.



Version 1.1 now has a functional Patch Mode (switch from Single to Mulit and vice versa). It didn’t want to do this at first. Cause: setting to Single Ptch Mode must happen from part A or part B MIDI channel, while setting to Multi must happen on the Global MIDI channel !

Now this is done, I was able to hide all unnecessary controls when in Single mode, and change the ARP1 MIDI channel according to chosen Path Mode as well. I hope it makes things more intuitive.

I’ve been trying to use the Summit patch as described (Part A=Ch2, Part B=Ch3, Global=Ch4) but when I use the Single Patch setting on summit I am not able to control Summit with ElectraOne. Maybe I’m misunderstanding how it works? When I edit the patch in ElectraOne App this is what I see (image). It looks like Ch4 is not set to Global as is described in the patch notes. Am I doing something wrong?

I changed the ‘Global Channel’ device above to ‘Port 1 - Channel 4’ and is communicating with Summit now. However the arpeggiator does all kinds of wacky stuff, it doesn’t seem to be set up right. For some rhythms and tempos it goes super fast and gets all glitchy. Others it starts and stops seemingly randomly. Is there possibly something wrong with the arpeggiator configuration?

BTW, I should have started by saying - Awesome preset! Thank you (and RobinC) so much for creating it. I’m just trying to stomp out some bugginess. I started with the default downloaded preset and this was how it was working.

EDIT: Also maybe I’m missing it, but I noticed Patch Request doesn’t seem to work. Is that not implemented for Summit?

I’ii check on it this weekend.

It’s a bit confusing. The MIDI channel of the Global channel on your Synth should match the midi channel of the E1 Device that is called “Global Channel”.
In my case I Used the fourth device (hence the confusion) on the E1 to represent Global Channel, and it is assigned to MIDI channel 1 .

Ensure your Summit is also assigned to MIDI Channel1 as Global channel. I’ll change the wording in the preset.

@markhw Hi Mark, did you manage to get it working?

Novation informed on Aug 3 about a firmware update V2.1. This has new delay FX features. The preset has been updated accordingly and is now also conveniently referred to as V2.1.

1 Like

Thanks NewIgnis. Yes I got it working. My problems with the arpeggiator were due to interference with midi from another device. Huge thanks for maintaining this preset! Retrieving parameter values for a current patch would be incredible but I assume that’s a lot of work or maybe even impossible so I won’t even ask… :wink:

1 Like

One day, Mark. One day.

But actually I’m finding some bugs in the MIDI implementation of the Summit. I still need to document those and provide them to Novation though.
Let me know if you encounter some weird behavior yourself.

Thanks, I will certainly let you know if I encounter anything.

FYI, on a separate note, it’s not super clear in the manual and the knob position on the Summit is misleading, but VCA Gain occurs in the audio path after the Post-Filter Drive, not before the Filter Overdrive as suggested by the parameter location in the preset.

the regular VCA, controlled by the amp envelope, comes after the filter, but this gain is from a VCA that has the mixer as input and feeds into the filter. It is meant to avoid undesired clipping. Do check the manual, look for ‘VCA gain’.

Interesting, my reading of the block diagram on manual p.21 is that the VCA Gain occurs after the voices are summed, after the filter > Pre-VCA distortion (aka Post-Filter Distortion). On p.28 when discussing resonance the manual says that (paraphrasing) high filter resonance can greatly increase the output signal level and cause unwanted clipping and “this can be compensated for by adjusting VCA Gain”. My reading of that is reducing VCA Gain will reduce the signal level after the filter stage. Am I misunderstanding?

EDIT: OK it seems pretty clear in the Mixer Section of the manual that there is an additional VCA Gain stage at the output so I will take your word for it! I think I was getting hung up on the fact that the suggestion to reduce VCA gain at high resonance levels feels a bit misleading because you’re not just “innocently” compensating for the gain in that case, you’re also totally changing how hard you hit the filter section and thus any overdriven tones there. The manual also says that VCA Gain effectively scales the amp envelope which is true, but again you may be completely altering your tonal profile going through the filter too.

The diagram is indeed confusing: the knob “VCA gain” impacts the ‘sum’ left of the filter, not the EG VCA at the right of the filter.

I quote the manual “ The three Oscillators, the Noise source and the Ring Modulator output each have level controls, Osc 1 38 , Osc 2 39 , Osc 3 40 , Noise 42 and Ring 1*2 41 respectively. There is also a “master” level control, VCA Gain 43 , which sets the output level of the mixer. ”

Using the VCA gain for overdrive may not (always) result in musical interest as it may clip ugly. That is probably why Novation added a pre-filter overdrive as well. With the gain you reduce the ugly clips, with the overdrive you add the musical ones.

Moog synths, like the Subsequent 37 or the Minimoog as well (afaik), do a similar thing, but with one knob only, per input: each of the oscillator level knobs serve as a gain until halfway, then it starts overdriving the osc.

Hey NewIgnis. Just wanted to report a bug and I didn’t know how to fix it. Both the ‘VCA Gain’ and FX ‘Routing’ controls seem to accidentally also control Osc2’s ModEnv2>Pitch control. I haven’t worked with NRPN yet and I can’t quite figure out why this would be happening, but maybe you can confirm. I tried redownloading your preset without any of my own modifications and am seeing the same issue.

Hi Mark, this does not look to be a bug by the presets, but in the Summit itself. It seems doing so with every NRPN control.

I checked if it was the CC 38, CC100 and/or CC101 that are in each of the NRPN messages the E1 makes and that are not really needed, but even when I filter them out, the same thing keeps happening.

So I opened a support ticket with Novation.

Hi Mark, I found the root cause:
Novation has been using CC 38 as a regular CC for controlling ModEnv2 => Pitch.
But actually CC 38 is reserved as Data Entry LSB for NRPN.
Since Novation isn’t using the CC 38 anywehre else in the Summit they haven’t discovered that mistake themselves.
I tried to fix it to make my own NRPN function, but somehow I can’t make it work, and the debugging functions is’t helpful currently; it gives me so much information after sending something to the Electra One, I can’t retrieve any error messages anymore… they’re off the screen.

Dang it, that’s a bummer to hear! Thanks for looking into it and I hope they get back to you on the use of CC 38. I’m currently looking into getting sysex definitions from Novation to see if I can work on reading the current patch state. I will let you know if I make any progress.

Don’t load in my preset yet, but check the latest preset you downloaded from me first. It contains the right SysEx request to get a patch and a bit of parsing. I don’t recall what I parsed, but you can see for yourself. In the latest preset I took it out again temporarily cause I’m getting other issues, probably memory issues. Anyŵay you can find the sysex request and reply byte sequences. I don’t have a SysEx implementation guide, nor has Novation, so we ll have to do the reverse engineering ourselves i’m afraid.

The reason I took it out is to make room for a bespoke NRPN function I wrote that skips CC38 all together so at least the controls would work correct. Probably something for this ŵeekend.

Last but not least, Novation acknowledged the issue, and were surprised no one mentioned it before. The Peak has the same issue and is already out there for 5years. Next steps are to be seen, but it looks like the development team will replace the current use of cc38 by something else in a future firmware.