[Solved] Martin, I need help! Electra will not start up correctly

Hi Martin. I just tried to use your Dynamic lists preset but my Electra freeze. It will not startup correctly.

I can see now that the preset was for 3.5, not 3.4 as I have. My mistake.

I have tried the factory reset but no success. What can I do to make it work again?

UPDATE: My Electra is alive again ::wink:

1 Like


the dynamic lists are available as of 3.5 (which is still in beta testing).

If the default preset does not allow E1 to start - (infinite loop, freeze, etc). Hold the top-left button during the start up. You need to hold the button from the moment when you connect the cable till the end of the start up animation.

This button combo will skip loading of the preset. You can then overwrite it or remove it.


Aaaah! There it is. Thanks! I’m having a hard time with 3.5rc4 on MkII on Windows 10 with Chrome having problems with a patch, reverting to an older firmware, load another patch, go to the rc4 again, switch back to misbehaving patch, try to fix problem, Electra get stuck, ad infinitum… Until now. :grinning::pray:t2:

1 Like

if you have troubles with a preset on 3.5 - you can always send me a link and I will review that.