[SOLVED] MIDI notes dropped via USB Host

Not sure whether this is a bug or just me in my first day with the E1…

I have a keyboard controller (SL Grand) connected to the USB Host. If I press keys, some notes will be eventually lost. No need to play virtuoso, I can reproduce the problem just by pressing a key every second for half a minute or less.

  • It happens on Linux and Windows with the same frequency, so I don’t think it’s my PC.
  • It happens only when I connect the controller to the E1 via USB, if I connect the controller to the PC directly it’s all fine, therefore it’s not the controller’s fault either.
  • It happens with two different apps (Bitwig and Numa Player) and therefore the app isn’t to blame either.
  • Connecting the controller to the E1 port 1 via MIDI DIN cable works just fine. No notes lost, which seems to isolate the problem to the USB Host.

I haven’t touched the initial E1 configuration. (Should I? For now I only plan to connect this controller to the E1 and all I want is a MIDI Thru going to the PC.)

Hi, I will look at it this weekend. I will ping you if I need any assistance or info from your side. Martin

1 Like

It is resolved. The fix will be included the upcoming release (today / tomorrow at latest). Thanks for reporting!


I’ll check as well. I had similar experience with an Arturia Keystep

1 Like

Please check the just-released v3.3.1. I made adjustments and tested that. I did see any notes missed any more.


I upgraded to 3.1.1, and… After one minute of my best piano trills :wink: not a single note was lost. The previous firmware would consistently show gaps within a minute. Problem solved!

Thank you, Martin.

1 Like

same here :wink:
all good!

1 Like