Status of Electra and iConectivity MIO10 connection via USB

Hi all!
I got my Electra One last week and have to say it’s an awesome piece of hardware. I love it! I did have a few hours to test it before having to prioritise other commitments. The did try to connect it via USB to my MIO10 but, as other people here has noted, it was hard to get it accepting presets. I have since tried different ways to solve it, making sure that there’s no filtering of sysex etc and that the routing is correct in Auracle and works, but to no avail. I’ve read up on everything written in this forum about the quite well known problems with iConnectivity units but I really couldn’t find a conclusive answer if it should work with the latest firmware release. The MIO10 is an earlier generation which maybe is part of the story?

So, have anyone got sending presets working via USB. Oh, by the way, I’m on Windows 10.

Thanks for all the (future) help. :slight_smile:

1 Like

I am also very interested in a mioxm or xl box.

i read from @martin that the mio mixes the ports up.

so you could just as a first step try to identify the controller port of the e.one.

for the rest i have no idea. do not own a miox… yet.

cheers

Thanks for the reply. I’m quite confident I have succeeded to connect the ports and route them correctly, I do get the notorious “Preset Transfer Failed, Please Retry” message every time I try to transfer…

Hi @Masarin,

Does the preset transfer work if you connect e1 directly to the computer? That is the first step to check.

With the mio, it is important to configure the ports I assume you have that done, otherwise you would not get the “Preset transfer failed” message. Just for the sake of completeness, the app.electra.one must be configured so that it communicates with Electra’s 3rd port (the CTRL port).

I have mioXM and mioXL, unfortunately not mio10. I quite sure that @RobinC has mio10 and I do think it works for him.

The “Preset transfer failed” message is shown when the preset transfer fails or the transferred data is incorrect. Is your mio10 running the latest available firmware?

I’ve got a MIO 10. I do remember an issue at one point with transferring presets but think that was corrected with a firmware update. My electras aren’t currently connected to my Mio 10 but will test at the weekend

1 Like

Similar issue here, the web page doesn’t see the Electra which is connected to my second Mio10. Otherwise the Electra is working fine in/thru Ableton Live.

Could it not be the case that the SysEx (from the Web app, containing the entire preset) is too large? Could you Mio 10 owners try with a tiny preset (only containing one page with one control), and see if that works?

I discussed this potential problem, and @martin has something in the works to fix it (breaking larger SysEx up in chunks), but not ready yet I suppose.

Hi everybody,

It’s been a while ! Almost same problem here with my Mio4.

Electra One is plugged to Mio4 USB Host and recognised by it. But the Electra One App doesn’t see it as connected even if I choose port 1, port 2 or port 3 in Mio4 configuration …

For the moment, I use Electra One with Din port to the Mio4 and USB to my computer (W10) but I will be simpler to avoid midi din cables :wink:

Edit : I just figure it out. Weirdly, I have to choose my Launchpad pro mk3 midi channel (In&Out) in the E1 app and the E1 is connected (port 3 selected in Mio4)

Problem solved but I still have to use both USB and DIN (without changing E1 port in the Mio) to use E1 as controler and editing it with the app

And I also have this “Preset Transfer Failed, Please Retry” message every time I try to transfer :confused:

This would be great. If anybody who has this “Transfer failed” issue on Mio4 or Mio10 tried to transfer a simple preset with only one control in it, it could give a hint if it is caused by the sysex limit in the router.

In the meantime I will contact iConnectivity tech support to see if they have any suggestions.

I’ll try to try it later this evening. “I’ll be back!” :robot: :slight_smile:

Found the following in the Mio4 firmware release notes:

Version: 1.0.3b1
Date: 2015-02-09

1. Made some changes to how MIDI messages are dispatched to hosted MIDI devices. Previously, it was possible to lose some MIDI events when sending large sysex messages to hosted MIDI devices.
2. Added support for hosting MIDI devices that have no OUT endpoint.
3. Now using EEPROM for saving user settings. This eliminates the need to shutdown USB and reboot the box every time settings are saved.

Version: 1.0.2
Date: 2014-07-21

1. Before writing to FLASH, USB ports are turned off. After writing to FLASH iCM4 is rebooted. This is necessary to prevent Mac and iPad from crashing if user happens to be passing audio when writing to FLASH.
2. Increased the size of the ring buffer for USB MIDI OUT endpoint (for rear USB port) from 256 to 2048 bytes. There were incidences where large sysex transfers under Windows were failing. No problem with Macs, just Windows. Front USB ports were not changed (not enough RAM on 11U14).
3. Added support for interrupt endpoints for MIDI data. Novation Launch series of controllers use interrupt endpoints, not bulk endpoints, which did not work with our USB host driver.

It looks like that these sysex issues should be completely resolved in their firmware 1.3 and higher.

Do you happen to know what router firmware you are running? It would be great to know before I reach their support anyways.

Thanks!

Hi Martin,

Firmware 2.21 here :wink:

I tried with a single 7 bit fader preset and it worked. Sysex size matter apparently !

2 Likes

Firmware 2.2.1 here too on my mio10. I created a preset and increased the number of fader controls. The transfer via mio10 worked up to including 11 faders, and failed with 12 and above.

1 Like

yeah, it most likely it is caused by the limit on size of sysex messages in Mio 4 / 10. As @joris.roling mentioned (and he is pushing on that feature for some time), the idea is that Electra would support transfer of large sysex messages in smaller size packets. That would allow transfer of presets when connected to devices that impose limits on that. And it would resolve the issue with output buffer size on Linux too.

3 Likes

2.2.1 on Mio10 here as well. Cannot transfer presets, additionally firmware update failed (but I managed both to do over normal USB)

Additional issues:
I have 2 ports defined for the Electra in AuracleX, the normal one for Ableton (2-HST2_Electra) and a second one for the web editor (2-HST4) (secondMIO-USBPORT_xx). When I load the web editor, Electra is not found, manually selecting the 2-HST4 port works and Electra gets detected.
BUT: I have to do this every time. Any way to save this? Even better: any way auto-discover could get improved? :slight_smile:

Both Mio10 are connected to the Windows PC over USB

1 Like

Yup, it was verified that Mio10 has a limit on maximum length of the SysEx messages. This brings back something that @joris.roling is asking for for ages. Transferring presets in smaller chunks. It is sort of recurring issue.

The firmware update is not a MIDI transfer and therefore it is not possible to do via the MIDI router. For firmware updates, Electra needs to be connected to the computer directly or via standard USB hub.

@tomas has that on his todo.

3 Likes