Switch page Again!

Hello ! I know the subject exists in multiple post . I read, almost, all.
I can’t figure out how to switch page from an external midi controller !

My set. the E1 is connected to my pc windows 10 through usb port . My stream deck is connected to the PC to through USB . I send PC from The Stream Deck to E1 with a fantastic midi plugin that works perfectly . It is made by Trevliga StreamDeck Midi plugin

I tried first to configure it through the configuration of the controller pannel .

It does not worked

I tried the

“version”: 1,
“midiControl”: [
“event”: “switchPage”,
“eventParameter”: 1,
“midiMessage”: “program”,
“parameterNumber”: 1
“event”: “switchPage”,
“eventParameter”: 2,
“midiMessage”: “program”,
“parameterNumber”: 2

Inpired by How to load Electra One banks and pages via my Morningstar MC8? - #3 by martin
Where martin explain how to do that with the hidden ( and pretty cool) Development Sandbox page.
Didn’t work to

My config seems simple .I think ?

I see the E1 receive it , it is also logged

…But nothing happen .

I tried to change to page 1 …or 2. nothing.
I mess something, i don’t know why it does not work .

Thanks for your help and have a nice day !

1 Like

Trying to do exactly the same, but not succeeding. It looks like it should be pretty straight forward. If I choose the Electra One as the port to send the message to, which would seem to make sense, the Streamdeck displays a ! icon.

Either way, it would make so much sense to use a stream deck to switch pages/presets/etc. of the Electra One.

1 Like

It is important to route the messages from the SteamDeck to Electra Controller CTRL port (Mac) or Electra Controller MIDI3 (windows). ie. it needs to go to the control port. Just tested that with LaunchPad Mini routed to Electra with Bome Network. It seems to work just fine.

1 Like

Hello Martin ! Thanks for your answer !
I already tried with the port 3 and had no luck until now . Still there are multiple problems and it does switch pages , just presets.
Then : Under windows 10

  1. It’s important to make the port 3 available .
    as it is exclusive they are not available once the web editor is open or the streamdeck is sending messages .
    Solution ? : would it be possible to send midi message to control E1 also on port 2 as an option?
    Here is my config . Ableton is on port 1, Editor port 3 and i don’t use port 2
  2. If the port “Electra Controller MIDI3” was used it does not respond to from another port . Even if you don’t send other messages from the previous device(Streamdeck) or closed the webapp.
    Useing boom midi translator could be a solution . will try.
  3. At the start (or restart) of the E1 When the port is available without any configuration the E1 respond to PC and switch presets.
    Tested that with streamdeck on “Electra Controller MIDI3”
    Would it be possible to do the same but with note and switch pages ? Then without any config we can swith preset with PC and pages with notes or CC…
    OK as i write this i also test with E1 . I found the way to make it work with Stream deck …Next post :slight_smile:

Okay, I got it to work. These are the settings in streamdeck using CC messages:

Here you can see the result:


I will pass some details .
Then for page switching with PC

  1. Pages begin at 1 . not 0. contrary to PC that start at 0. At some point it can be tricky :sweat_smile:
  2. Configure the pages switching on the E1

Once done , on streamdeck: to recall pages
Configure PC
Strmdck E1 PC conf

If it does not work . And it can work not :sweat_smile:
I accidentaly activate the “state” to switch pages by sending a CC message to the same port and sending a CC0 with value 127 .
Streamdeck CC0

Then each PC sent with no “coarse” nor “fine” will page switch … :grin:
And that’s even great ! cause it is for me the best way to switch page or preset or snap depending with value you send on CC 0 and using only PC !!!

This is the second way to use it .
Create some PC
Strmdck E1 PC only conf
Then with no coarse nor fine.

Then creat 3 CC0 button :grin: with value 0,1 and 127. push mode .
CC0 value 0 is for preset change
Streamdeck sending preset
CC0 with value 1 is for snap change
CC0 with value 127 is for page switching …that’s the one i was looking for.

Then now : ON CC0 (i wrote a mistake and corrected it by editing).
if you push CC0 value 0 all PC will now switch presets regarding the PC value
if you push CC0 value 1 all PC will switch snaps regarding the PC value
if you push CC0 value 127 all PC will switch pages regarding the PC value and the configuration of the E1 on the webapp :wink:

I supose regarding another CC value on the CC0 it will switch the bank ?


That’s cool ! my example is regarding PC (and CC) ! lol. We were in sync :wink:

1 Like

Hello gents,

thanks for sharing all the details. It seems I’m the next one in the loop… :upside_down_face:

Inspired by your posts I decided to give it a try but so far without any success.

Before I go into details: Is a lua script necessary to get this to work or is this already implemented?

My log window shows the following messages at the end after I tried to send a Program Change command to E1:

19:14:08.874 lua: function onClock does not exist
19:14:08.875 lua: function onStart does not exist
19:14:08.875 lua: function onStop does not exist
19:14:08.876 lua: function onContinue does not exist
19:14:08.877 lua: function onActiveSensing does not exist
19:14:08.877 lua: function onSystemReset does not exist
19:14:08.878 lua: function onTuneRequest does not exist
19:14:08.878 lua: function onProgramChange does not exist
19:14:08.879 lua: function onAfterTouchChannel does not exist
19:14:08.880 lua: function onPitchBend does not exist
19:14:08.880 lua: function onSongSelect does not exist
19:14:08.881 lua: function onSongPosition does not exist
19:14:08.882 lua: function onControlChange does not exist
19:14:08.882 lua: function onNoteOn does not exist
19:14:08.883 lua: function onNoteOff does not exist
19:14:08.884 lua: function onAfterTouchPoly does not exist
19:14:08.885 lua: function onSysex does not exist
19:14:08.885 lua: function onMessage does not exist

Thanks in advance for some enlightening.



Hello @HaPe !
No script needed just to configure the electra one

I finally used the CC for page switching . Both method work

The messages have been sent on port 3 off the E1 , the control port .
that’s why i had to switch ON/OFF between using the webapp and using the control port with the StreamDeck .
And that’s why i suggested as a possible solution to make the Port 2 available as an option to also control the E1 .

it would then be possible to control the E1 with the Stream Deck with port 2 and using the webapp on port 3 :slight_smile:
Also i am on windows , if you are on mac it could be different regarding the port ?
Have a nice day ! . :grin:

Edit : Also i noticed that the Stream Deck could block the E1 port 3 even if you don’t send anything ,Once the connection is made . then time to time i have to switch off my StreamDeck if i want to edit the E1 with the webapp :joy: :wink:

1 Like

Thanks so much @Abbes for your kind and helpful reply.

I am on Mac. And I am sure that I am sending to the E1 Control Port. I always use a pretty smart MIDI monitor that gives me very detailed informations about MIDI data being sent.

My current configuration is as follows:



I am currently not using Stream Deck but Keyboard Maestro to send the PRG Change command. The following screenshot from my MIDI Monitor shows that it transfers the command to the E1 CTRL Port. I also can see its reaction on the E1 screen.


More or less by mistake this morning I recognized that it changes to page 1 of Preset 1 whenever I have selected a different preset or bank except 1. And BTW it doesn’t matter if I send the PRG change 1 or 128 or 126 etc…

I understand the command “Switch to page” to switch pages within a preset or a bank.

Sorry, I can’t get this. Could you please explain a bit more what and where you can switch between the web app and other controllers? I am not aware of any switch regarding the web app. Maybe that is the issue? I completely closed the web app but the behaviour didn’t change.

Thanks again and have a great weekend! :sunglasses:

Yes it happened to me to . when i was testing with PC , sending a CC0 value 127 made the trick . after that it switches pages instead of presets witch the PC configuration .

I understand the command “Switch to page” to switch pages within a preset or a bank.

“switch pages” changes pages of a preset, not a preset nor a bank … if i am not wrong :sweat_smile:
“swicth presets” changes presets on a bank …
You can also change snaps by sending CC0 value 1 and using PC after that .
I didn’t find how to change bank

I don’t know how it works on Mac but on Windows while the Webapp is open (using chrome or vivaldi on my current windows config) the port 3 is locked on it (chrome or vivaldi) . Then i can’t send any messages on the E1. Midi port on windows are for the big majority exclusive . I know some drivers are not but regarding The E1 it is .
Then when i finished to configure the E1 with the webapp i had to close the webapp, switch off (disconnect the USB cable or in my case i use a usb hub with switch button) and switch on again the E1 . If i only i close the Webapp , the stream deck can’t access it . The port still get locked .
One way to know if you actually receive the message for shure is to see if the “USB MIDI” on the upper left cornet of the E1 blink

Same thing happen while i want to re-use the E1 with the Web app . i have to close The stream deck application and switch off the E1 . Then switch on the E1 and open again the Webapp :grin:
Perhaps you have to do the same thing with Keyboard Maestro ?


In the process of making the E1 react, the first thing was just to send PC 0,1,2,3,etc to swtich presets after configuring the Midi control panel of the web app .
Natively it should switch the presets .
Sending just PC , no bank, no sub bank .
That’s the first thing i managed to do before i went further in my “switch page aventure”

Have a good evening in experimenting with E1! :grin:

Edit : Important info : The E1 behave weirdely if the USB hub have not enough power ! really weirdely . I have seen E1 self changing knobs focus of the screen like if i touched the screen . I thought it was a hardware problem, but not . i put it on a USB powered and all came back to normal .


Electra needs stable supply of around 500mA current at 5V. When the current cannot be delivered or the voltage bends down, the touch sensing chips (LCD and knobs) may act weird. This is usually results in “random virtual touches”. This can be prevented by using powered hubs, quality cables, etc.

1 Like

Thanks again @Abbes for your detailed description.

I don’t need to quit something. I can use the port from the web app and other apps. As mentioned I can see what’s being sent with my MIDI monitor and the reaction on the E1 CTRL port (flashing).

I even experimented sending the CC message you mentioned but it didn’t help. I’m also probably by far not able to get the magic behind it.

If the configuration under “MIDI CONTROL” is set to receive PC messages I’d expect it to behave like this.

I will give up and maybe come back to it when it becomes more important for me. I already spent way too much time with all this tests.

Thanks again!