Editor app doesn't seem to be working correctly [SOLVED]

It doesn’t capture sysex info and now offers an exciting array of mystery controls to choose from. Also, changes and updates to presets aren’t being saved on exit.

update: some clearing of browser cache and saved data helped the button text render but the editor is still not capturing data via MIDI learn nor saving updated preset upon exit.

Which browser?
Are you properly connected? (Green button)


Do you get this all the time? When you it happens try doing SHIFT + reload. Let me know if it helps. In the meantime I will try to do some research on what it could be. I can see MIDI learn produces empty controls, will try to get it fixed asap.

shift+reload didn’t change anything.

Other info that might be useful in diagnosis:

I’ve been working on a big preset. For a couple of hours a day over the last week I’ve been using MIDI learn to capture and configure controls. Nothing in the setup has changed and there have been no browser updates, etc. Yesterday, when I sat down to work on it, the app no longer learned controls and no longer saved changes to any of my saved presets. I can make new controls if I manually enter the data but they aren’t saved upon exit. I haven’t tried sending an updated preset from the editor app to the device because in case there is something strange happening in the preset formatting, I don’t want to overwrite a working preset with a non-working one.

At first I thought it might be due to the particular formatting of the sysex commands I’m working with but further investigation shows that the app won’t recognize basic CC’s or NRPN info.

I’ve tried to save changes to the device list and those aren’t saved either.

So yeah, hopefully that helps.

Ok, then forget my previous question, you seem to know what you are doing :blush:

The MIDI learn should be working now. I was able to replicate the problem. The fix was just released. It was an issue in the Editor, no need to update firmware or anything. Shift-reload of the Editor might be a good idea.

I was not able to replicate the problem with saving presets. I keep investigating it.

MIDI learn now behaves differently but does not work for me. Instead of a blank control I see the message “detected incoming midi message on port 1” it pulses as the control is moved but it never becomes a control.

I think I’ve made some headway on the saving thing though. I have the zoom setting in chrome set to 75% in order to fit a bunch of shit on the screen at the same time. If the zoom is set to 80% or above, saving works. At 75% or below, saving does not work.

@S_L_L , pls try the midi learn with the new firmware 1.3. We made a few small changes and it works on our side. If the update does not work for you I will try to research it more.

Progress! The page zoom thing seems to not be an issue any more, CC’s are working, but I’m still not capturing sysex messages. If I manually enter sysex info into a control, the control works. If I try to capture it via MIDI learn, the app does not recognize it as a sysex message.

I have a bit of a workaround going at the moment where I can use a MIDI monitor to capture the sysex info and then I can just copy it into the Electra editor but, again, it was all working correctly until recently.

New firmware looks great. I’m playing around with the envelopes now. They’re very well done.

1 Like

Just repliaced that. I think there is an issue caused by the fact that the MIDI learn expects messages on given MIDI channel. That is not valid for SysEx messages. Will try to get it fixed. Thanks for giving perfect description to identify it!

Btw: my Chrome Browser is filled with a lot plugins and there are some issues.

For the MIDI editor I use a clean browser is only there for Electra One: Opera (based on Chrome too) :slight_smile:

@S_L_L , please try that now. You should be able to capture SysEx messages now.

IT WORKS!!! I really appreciate you making it happen. :grinning: